Wiki

Clone wiki

deadbeef-qt / Home

Deadbeef

DB is available at http://deadbeef.sourceforge.net/

Installation

Qt 4.4 or greater is required to compile.

First, you need to install DeaDBeeF with version 0.3.3.

Then get deadbeef-qt sources from repository:

$ hg clone https://bitbucket.org/tonn/deadbeef-qt/

Create temporary directory (for example </path/to/sources>/build) and change into it:

$ cd qtgui
$ mkdir build
$ cd build

Run cmake:

$ cmake -D CMAKE_INSTALL_PREFIX=<DEADBEEF_INSTALL_PREFIX> ../

where the variable <DEADBEEF_INSTALL_PREFIX> is typically /usr

Then run make:

$ make
# make install

And finally you need to disable default DeaDBeeF ui plugin. Add next string to ~/.config/deadbeef/config file:

blacklist_plugins gtkui

Gentoo

Ebuild deadbeef-qt.ebuild by question4.

Screenshot

2010-01-10-233414

Updated