1. Hiroyoshi Komatsu
  2. corenlp-python
  3. Issues
Issue #5 resolved

Failed to load choosed modules in true verbose options

Hiroyoshi Komatsu
repo owner created an issue

If choosed models in a properties file, and verbose option is true, failed to load the models.

This problem does not appear when verbose option is false, so probably it is easy to solve, but we must think the interface to properties files.

Thanks for reporting Paulo Malvar Fernández in e-mails.

Comments (7)

  1. Paulo Malvar

    I have tried running corenlp.py using the -q flag (verbose=False), but I still can't get the script to load successfully. I have tried this in both Mac OS X and Ubuntu 12.04 and I always get a timeout error like this:

    Traceback (most recent call last): File "./corenlp.py", line 504, in <module> nlp = StanfordCoreNLP(options.corenlp, properties=options.properties) File "./corenlp.py", line 364, in init self.corenlp.expect("\nNLP> ", timeout=3) File "/usr/lib/python2.7/dist-packages/pexpect.py", line 1311, in expect return self.expect_list(compiled_pattern_list, timeout, searchwindowsize) File "/usr/lib/python2.7/dist-packages/pexpect.py", line 1325, in expect_list return self.expect_loop(searcher_re(pattern_list), timeout, searchwindowsize) File "/usr/lib/python2.7/dist-packages/pexpect.py", line 1409, in expect_loop raise TIMEOUT (str(e) + '\n' + str(self)) pexpect.TIMEOUT: Timeout exceeded in read_nonblocking(). <pexpect.spawn object at 0x268cad0> version: 2.3 ($Revision: 399 $) command: /usr/bin/java args: ['/usr/bin/java', '-Xmx3g', '-cp', 'stanford-corenlp-full-2013-06-20/stanford-corenlp-3.2.0.jar:stanford-corenlp-full-2013-06-20/stanford-corenlp-3.2.0-models.jar:stanford-corenlp-full-2013-06-20/xom.jar:stanford-corenlp-full-2013-06-20/joda-time.jar:stanford-corenlp-full-2013-06-20/jollyday.jar', 'edu.stanford.nlp.pipeline.StanfordCoreNLP', '-props', 'default.properties'] searcher: searcher_re: 0: re.compile(" NLP> ") buffer (last 100 chars): ner Loading classifier from edu/stanford/nlp/models/ner/english.all.3class.distsim.crf.ser.gz ... before (last 100 chars): ner Loading classifier from edu/stanford/nlp/models/ner/english.all.3class.distsim.crf.ser.gz ... after: <class 'pexpect.TIMEOUT'> match: None match_index: None exitstatus: None flag_eof: False pid: 2581 child_fd: 4 closed: False timeout: 30 delimiter: <class 'pexpect.EOF'> logfile: None logfile_read: None logfile_send: None maxread: 2000 ignorecase: False searchwindowsize: None delaybeforesend: 0.05 delayafterclose: 0.1 delayafterterminate: 0.1

  2. Hiroyoshi Komatsu reporter

    Relwell's repository in GitHub is not a repository of me, which is a fork. If you use his repository, please report the issue in it. I think either way is not different so much. His repository added multi-threaded load balancing from my repository, but it looks like forked from an old version of my repository.

  3. Paulo Malvar

    I'm very sorry for the misunderstanding, but since you were listed first in the Developer list of that GitHub repository I thought you were also responsible for it. My apologies again.

  4. Log in to comment