Issue #1155 resolved

Clone fails with missing overload for currentIndexChanged(int)

cohen23
created an issue

Under Ubuntu 10.10 I tried to clone an HG repo from a USB drive, and got this. The repo was created on a Windows box using a newer version of TortoiseHG. I have successfully cloned this repo on another Wndows box.

Here is the text from the TortoiseHG Bug Report window:

{{{

!python

Mercurial version (1.9.1). TortoiseHg version (2.1.2+83-38a0fe948127) Command: clone CWD: /media/PATRIOT/DOWChemical+HG Encoding: UTF-8 Extensions loaded: extdiff, rebase Python version: 2.6.6 (r266:84292, Sep 15 2010, 16:22:56) [GCC 4.4.5] Qt-4.7.0 PyQt-4.7.4 Traceback (most recent call last): File "/usr/lib/pymodules/python2.6/tortoisehg/hgqt/run.py", line 547, in __call__ dlg = dlgfunc(ui, *args, opts) File "/usr/lib/pymodules/python2.6/tortoisehg/hgqt/clone.py", line 526, in run return CloneDialog(pats, opts) File "/usr/lib/pymodules/python2.6/tortoisehg/hgqt/clone.py", line 200, in init self.src_combo.currentIndexChanged.connect(self.onResetDefault) TypeError: onResetDefault() has no overload that is compatible with currentIndexChanged(int)

}}}

Comments (1)

  1. Log in to comment