Issue #691 resolved

linux-Workbench not working

Fiction City
created an issue

running thg throws this error since today update:

{{{ Traceback (most recent call last): File "/usr/bin/thg", line 72, in <module> ret = tortoisehg.hgqt.run.dispatch(sys.argv[1:]) File "/usr/lib/pymodules/python2.7/mercurial/demandimport.py", line 75, in getattribute self.load() File "/usr/lib/pymodules/python2.7/mercurial/demandimport.py", line 47, in _load mod = _origimport(head, globals, locals) File "/usr/lib/pymodules/python2.7/tortoisehg/hgqt/run.py", line 361, in <module> class _QtRunner(QObject): File "/usr/lib/pymodules/python2.7/tortoisehg/hgqt/run.py", line 374, in _QtRunner error.RepoLookupError: ('Try refreshing your repository.'), File "/usr/lib/pymodules/python2.7/tortoisehg/util/i18n.py", line 77, in agettext return hglib.fromutf(u) File "/usr/lib/pymodules/python2.7/mercurial/demandimport.py", line 75, in getattribute self._load() File "/usr/lib/pymodules/python2.7/mercurial/demandimport.py", line 47, in _load mod = _origimport(head, globals, locals) File "/usr/lib/pymodules/python2.7/tortoisehg/util/hglib.py", line 25, in <module> from mercurial.util import canonpath, user_rcpath ImportError: cannot import name canonpath

}}} Mercurial Version: hg --version Mercurial Distributed SCM (version 1.8.3+25-d8ba6fb2ce15)

Comments (6)

  1. Steve Borho

    Your thg install is too old. You need tip of default thg to run with tip of default Mercurial. I suggest nuking what you have installed and running out of a clone.

  2. maugustin

    "ImportError: cannot import name canonpath" still experiencing on Ubuntu 10.04 with:

    tortoisehg_2.1.1+35-bb515093a3d2-0ppa1~lucid1_all.deb
    mercurial_1.9~1.8.3+25-d8ba6fb2ce15-0ppa1~lucid1_i386.deb
    mercurial-common_1.9~1.8.3+25-d8ba6fb2ce15-0ppa1~lucid1_all.deb
    

    Kind regards Michael

  3. André Sintzoff

    You are running incompatible versions of Mercurial (1.8.3) and TortoiseHg (2.1.1). You have to update Mercurial with 1.9 version.

    When starting TortoiseHg, I'm surprised you don't get a message like:

    This version of TortoiseHg requires Mercurial version 1.9.n to 1.10.n, but found 1.8.3
    
  4. Log in to comment