no attribute 'bail_if_changed'

Anonymous avatarAnonymous created an issue

I have a new installation of TortoiseHg Version 2.1.1. When I try to open the Workbench, clone a repository, or perform any command, I get the following error:

** Mercurial version (1.9+10-e9264b45237d).  TortoiseHg version (2.1.1)
** Command: --nofork workbench
** CWD: C:\Users\artj.BEDROCK\Documents\Projects
** Extensions loaded: fetch, kilnauth, kilnpath, big-push, kiln, caseguard, kbfiles
** Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:13:38) [MSC v.1500 64 bit (AMD64)]
** Windows version: (6, 1, 7601, 2, 'Service Pack 1')
** Processor architecture: x64
** Qt-4.7.1 PyQt-4.8.3
Traceback (most recent call last):
  File "tortoisehg\hgqt\run.pyo", line 50, in dispatch
  File "tortoisehg\hgqt\run.pyo", line 236, in _runcatch
  File "tortoisehg\hgqt\run.pyo", line 296, in runcommand
  File "mercurial\extensions.pyo", line 102, in loadall
  File "C:\Users\artj.BEDROCK\AppData\Local\KilnExtensions\kbfiles\bfsetup.py", line 1038, in uisetup
  File "mercurial\extensions.pyo", line 184, in wrapfunction
AttributeError: 'module' object has no attribute 'bail_if_changed'

Comments (34)

  1. Anonymous

    Not in install location.

    See above, error is pointing to "C:\Users\artj.BEDROCK\AppData\Local\KilnExtensions\kbfiles\bfsetup.py", so find folder C:\Users\{User}\AppData\Local\KilnExtensions\kbfiles replacing {User} with your username.

  2. benlaf

    Thank you for your prompt reply.

    But I cannot find one single ".pyo" on my PC.....?!

    Nor can I find the "KilnExtensions" folder at the specified location or anywhere else... And lastly, there is not bfsetup.py on my HD......?!

    I am starting to wonder if we are talking about the same issue....?!

    Update : there is a file named "bfsetup.py" (not pyo) located here : "C:\Program Files\Kiln Client\kbfiles".

    Your help is greatly appreciated...

    Ben

    --------------------- Update : issue resolved : deleted the "Kiln Client" folder from C:\Program Files. Maybe from a previous installed or an undocumented conflict ?

    Do not quite understand what it has got to do with the error (based on previous comments in this thread) but maybe the info can benefit the community! Thank you for your replies !

    Ben

  3. Log in to comment
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.