1. TortoiseHg
  2. TortoiseHg
  3. thg
  4. Issues
Issue #1378 invalid

thg but supported mercurial 2.0?

Djam
created an issue

{{{

!python

Mercurial version (2.0). TortoiseHg version (2.1.4) Command: CWD: /home/serg Encoding: UTF-8 Extensions loaded: Python version: 2.6.5 (r265:79063, May 20 2011, 13:23:49) [GCC 4.4.3] ** Qt-4.6.2 PyQt-4.7.3

This version of TortoiseHg requires Mercurial version 1.9.n to 1.10.n, but found 2.0

}}}

Comments (7)

  1. Benjamin Morales

    Why is the status set to "invalid"? How can I solve this?

    Mercurial version (2.1). TortoiseHg version (2.2) Command: CWD: /home/bamr Encoding: UTF-8 Extensions loaded: Python version: 2.7.2+ (default, Oct 4 2011, 20:06:09) [GCC 4.6.1] Qt-4.7.3 PyQt-4.8.5

    This version of TortoiseHg requires Mercurial version 1.9.n to 2.0.n, but found 2.1

  2. Miquel Burns

    Benjamin, your error is in issue #1583

    The happens almost every time there's a new major release of Mercurial, as Mercurial doesn't do much to prevent breaking extensions between major releases (and THG is technically an extension)

  3. Benjamin Morales

    thanks for answer,

    I did the next workaround.

    1. Download the tortoisehg-2.2.2 source and unzip
    2. Edit the file "tortoisehg/util/hgversion.py"
      change the line
      nextver = map(str, divmod(int(reqver[0]) * 10 + int(reqver[1]) + 1, 10))
      which gives nextver = 2.0
      for the next line, which gives nextver = 2.1
      nextver = map(str, divmod(int(reqver[0]) * 10 + int(reqver[1]) + 2, 10))
    3. run ./thg and that's it
  4. maugustin

    This is still occuring. I'v installed via MacPorts on OSX 10.7: THG 2.1.2 with Mercurial-2.2.2, Python-2.7.3, PyQt-4.9.1, Qt-4.8.2

    used workaround in tortoisehg/util/hgversion.py

    replace if vers == reqver or len(vers) < 2: with if vers == reqver or len(vers) < 20:

    from Anonymous

  5. Log in to comment