1. TortoiseHg
  2. TortoiseHg
  3. thg
Issue #1509 closed

failure on file import

duncanparsons
created an issue

after having just successfully imported a changeset file in workbench (following a remote corruption), trying to import another using the same method (Repository->Import...) failed giving this: {{{

!python

Mercurial version (2.0.1). TortoiseHg version (2.2.1) Command: --nofork workbench CWD: G:\DropBox\My Dropbox\GForce-Hg\gflib Encoding: cp1252 Extensions loaded: Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)] Windows version: (5, 1, 2600, 2, 'Service Pack 3') Processor architecture: x86 ** Qt-4.7.4 PyQt-4.8.6 Traceback (most recent call last): File "tortoisehg\hgqt\thgimport.pyo", line 156, in checkStatus File "mercurial\context.pyo", line 738, in status File "mercurial\localrepo.pyo", line 1303, in status File "mercurial\context.pyo", line 372, in cmp File "mercurial\context.pyo", line 364, in size File "mercurial\util.pyo", line 236, in get File "mercurial\context.pyo", line 278, in _filerev File "mercurial\util.pyo", line 236, in get File "mercurial\context.pyo", line 272, in _filenode File "mercurial\revlog.pyo", line 776, in lookup LookupError: data/src/gflib/gflView.cpp.i@290b15ddac02: no match found

}}}

Closing and trying again repeats the same error. I can see that there's an issue with the file gflView.cpp on my part.

Hope that helps!

Comments (3)

  1. duncanparsons reporter

    Apologies for very late reply! I'm doing more on this project after a couple of months not doing so much.

    Didn't know about the Verify command - it fails. Many messages of a form: data/src/gflib/tests/TestMessage.h.i@0: missing revlog! 0: empty or missing src/gflib/tests/TestMessage.h

    in relation to the specific file mentioned in the original post the verify says: src/gflib/gflView.cpp@?: rev 2 points to nonexistent changeset 8 (expected ) src/gflib/gflView.cpp@?: 6f2d91e1a3dd not in manifests src/gflib/gflView.cpp@?: rev 3 points to nonexistent changeset 9 (expected ) src/gflib/gflView.cpp@?: 245ea4af668c not in manifests src/gflib/gflView.h@?: rev 2 points to nonexistent changeset 8 (expected ) src/gflib/gflView.h@?: 0caf557ccaa3 not in manifests src/gflib/gflView.h@?: rev 3 points to nonexistent changeset 9 (expected ) src/gflib/gflView.h@?: 8f219ae32e36 not in manifests

    This is a repository I inherited, it was created from an older SVN repository. So I don't know what can be done in rebuilding it - hg has not been one of the cornerstones of my dev tools, so I'm less familiar with how it does what it does, and its toolset.

    I tried 'Recover' but to no avail, it giving: no interrupted transaction available [command returned code 1 Mon Apr 30 16:55:05 2012]

    which seems fair enough, as I'm not trying to recover a transaction, as such.

    So - I don't know if this still constitutes a thg bug, or whether this is a result of a poorly implemented repository way back when. Any help would be greatly appreciated!

  2. Log in to comment