Issue #1762 invalid

Tortoisehg not showing context menu properly, XP SP3

chospo
created an issue

Hello

I was evaluating TortoiseSVN when I heard about Mercurial. Decided to install TortoiseHg without uninstalling SVN. After seeing context menu icon issues (which I deduced they'd be because of the conflict between both frontends) decided to uninstall SVN.

Reboot and everything fine. Created a dummy repository, and right-clicking it shows the common context menu (with Commit, Workbench and other operations like Add,Remove,Update,Merge,...)

The problem is, that right-clicking any other file results in having the pre-repository two element context file: Workbench and the submenu with "Clone, Create Rep here, Global Settings, About".

Given that, TortoiseHg is not usable for me right now... Tried to uninstall, delete every regedit key and trace that could wonder, and reinstall plus reboot before touching anything. But the result is the same.

Thank you.

Comments (8)

  1. chospo reporter

    With a repo created, tried "hg status" from the command line. If inside the repo folder, the GUI shows up. Elsewhere, throws error that "No repository found in <Execution Path> (.hg not found)!". Same with "hg add".

    ¿Maybe a PATH issue?

  2. Log in to comment