Issue #182 invalid

ERROR "__init__() takes exactly 5 arguments (4 given)" when updating to a revision

dpupek
created an issue

If I try to update to a revision I receive the error:

{{{

!python

% hg update --repository C:\sandboxes\WebStudio --verbose --config ui.merge=internal:fail --rev 96 --clean init() takes exactly 5 arguments (4 given) [command returned code 255 Wed Mar 02 10:36:20 2011]

}}} Here is a screen shot of the error:

http://screencast.com/t/YgUycFXLIe

Comments (7)

  1. Anonymous

    Not sure if this helps, but I had the same problem, but now it works again (not sure why).

    I upgraded from Tortoise 1.1.9 to 2.0 (did not uninstall 1.1.9 before as I thought 2.0 would do it) and I could no longer update to a revision in any of my repositories (same message as dpupek had). If I uninstall 2.0 and reinstall 1.1.9. they all worked just fine. My installation uses all default switches. I have not intentionally enabled any extensions. Then I uninstalled 1.1.9. and installed 2.0 again and suddenly updates worked again on all repositories. Another thing that might be relevant was that when I upgraded the first time my head was not at the tip and my first action with 2.0 was to update to the tip (which failed as did all following attempts to update to any arbitrary revision). When I restored 1.1.9, I updated my head to the tip and then re-installed 2.0 to attempt updating to an old revision (this time successfully).

  2. Log in to comment