Issue #2044 invalid

Problems when using together with EncFs4Win

Peter Grman
created an issue

hi, I have just copied my repository to an EncFs virtual partition in windows and get now following bug report:

{{{

!python

Mercurial version (2.1.1). TortoiseHg version (2.3.1) Command: CWD: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\TortoiseHg Encoding: cp1252 Extensions loaded: bugzilla Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:13:38) [MSC v.1500 64 bit (AMD64)] Windows version: (6, 1, 7601, 2, 'Service Pack 1') Processor architecture: x64 ** Qt-4.7.4 PyQt-4.8.6 Traceback (most recent call last): File "tortoisehg\hgqt\fileview.pyo", line 339, in displayFile File "tortoisehg\hgqt\filedata.pyo", line 26, in init File "tortoisehg\hgqt\filedata.pyo", line 347, in readStatus File "tortoisehg\hgqt\filedata.pyo", line 40, in checkMaxDiff File "mercurial\util.pyo", line 237, in get File "mercurial\context.pyo", line 288, in _filelog File "mercurial\localrepo.pyo", line 654, in file File "mercurial\filelog.pyo", line 35, in init File "mercurial\revlog.pyo", line 263, in init RevlogError: index data/BAP/Content/background.gif.i unknown format 51937

}}}

Comments (3)

  1. Peter Grman reporter

    hi, I did also a small research on EncFs4Win and figured out that many ppl had problems with their files (even savin word documents, ...) so i guess it's a problem of EncFs4Win

    The original repository still works.

    sry for bothering you, thx for the fast reply

  2. Log in to comment