1. TortoiseHg
  2. TortoiseHg
  3. thg
  4. Issues
Issue #2198 invalid

Getting '20-byte hash required' message on commit

Bill Martin
created an issue

I was experiencing an issue with a repository that would error with a 'No Node' message when viewing in Tortoise Workbench. So, I upgraded to TortoiseHg 2.5.1 and am now receiving '20-byte hash required' when i try to commit. I was able to commit before. I couldn't find anything about this message on the web. I tried a hg verify and there were no issues.

Attached is the bug report.

** Mercurial version (2.3.2).  TortoiseHg version (2.5.1)
** Command: --nofork workbench
** CWD: D:\Code Library\DDKS\DDKSCodeLibrary\4.0
** Encoding: cp1252
** Extensions loaded: 
** Python version: 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]
** Windows version: sys.getwindowsversion(major=5, minor=2, build=3790, platform=2, service_pack='Service Pack 2')
** Processor architecture: x86
** Qt-4.8.0 PyQt-4.9.1
Traceback (most recent call last):
  File "tortoisehg\hgqt\run.pyo", line 554, in __call__
  File "tortoisehg\hgqt\workbench.pyo", line 1287, in run
  File "tortoisehg\hgqt\workbench.pyo", line 601, in showRepo
  File "tortoisehg\hgqt\workbench.pyo", line 936, in _openRepo
  File "tortoisehg\hgqt\workbench.pyo", line 778, in addRepoTab
  File "tortoisehg\hgqt\repowidget.pyo", line 112, in __init__
  File "tortoisehg\hgqt\repowidget.pyo", line 164, in setupUi
  File "tortoisehg\hgqt\repofilter.pyo", line 112, in __init__
  File "tortoisehg\hgqt\repofilter.pyo", line 309, in refresh
  File "tortoisehg\hgqt\repofilter.pyo", line 262, in _updatebranchfilter
  File "mercurial\util.pyo", line 245, in __get__
  File "tortoisehg\hgqt\thgrepo.pyo", line 455, in namedbranches
  File "mercurial\localrepo.pyo", line 651, in branchtags
  File "mercurial\localrepo.pyo", line 629, in branchmap
  File "mercurial\localrepo.pyo", line 623, in updatebranchcache
  File "mercurial\localrepo.pyo", line 605, in _branchtags
  File "mercurial\localrepo.pyo", line 754, in _updatebranchcache
  File "mercurial\revlog.pyo", line 267, in hasnode
  File "mercurial\revlog.pyo", line 281, in rev
ValueError: 20-byte hash required

Comments (9)

  1. Bill Martin reporter

    (Reply via BMa...@deltadentalks.com):

    Hi Steve, That's what I thought. When I run it, I get this:

    checking changesets checking manifests crosschecking files in changesets and manifests checking files 110 files, 21 changesets, 239 total revisions

    Anything else I can try?

    -----Original Message----- From: Steve Borho [mailto:issues-reply@bitbucket.org] Sent: Thursday, October 11, 2012 3:26 PM To: Bill Martin Subject: Re: [tortoisehg/thg] Getting '20-byte hash required' message on commit (issue #2198)

  2. Log in to comment