1. TortoiseHg
  2. TortoiseHg
  3. thg
  4. Issues
Issue #2275 resolved

TortoiseHg detecting hg 2.4

pc4500
created an issue

When starting any command from TortoiseHg, this pops up in the bug report window:

** Mercurial version (2.4).  TortoiseHg version (2.1.2)
** Command: --nofork init /home/ys/Documents/CocaineAddicProject.odt
** CWD: /home/ys
** Encoding: UTF-8
** Extensions loaded: 
** Python version: 2.7.3 (default, Apr 14 2012, 08:58:41) [GCC]
** Qt-4.8.1 PyQt-4.9.1

This version of TortoiseHg requires Mercurial version 1.9.n to 1.10.n, but found 2.4

Please excuse the command part, i have a project to work on

Comments (4)

  1. André Sintzoff
    • edited description

    As the message said, you have incompatible versions.

    Latest release of TortoiseHg is 2.5.1. It is compatible with Mercurial version 2.3.2.

    You should update TortoiseHg to 2.5.1 and downgrade Mercurial to 2.3.2.

  2. Log in to comment