Cannot use THG after attempting an upgrade

Issue #2409 duplicate
Anonymous created an issue

I had an older version of THG (through Fog Creek / Kiln) and attempted an update to the newest version. The upgrade went poorly (upgrade reported that Windows Explorer was running when all other windows were closed, then Windows lost all UI elements). I rebooted, removed the THG and Kiln clients, rebooted again, and re-installed the THG/Kiln Client. I now get this error when attempting to run the Hg Workbench:

** Mercurial version (2.2.2).  TortoiseHg version (2.4.1)
** Command: --nofork workbench
** CWD: C:\AllianceWeb
** Encoding: cp1252
** Extensions loaded: kbfiles, fetch, gestalt, kilnauth, kilnpath, big-push, kiln, caseguard
** Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:13:38) [MSC v.1500 64 bit (AMD64)]
** Windows version: (6, 1, 7601, 2, 'Service Pack 1')
** Processor architecture: x64
** Qt-4.7.4 PyQt-4.8.6
Traceback (most recent call last):
  File "tortoisehg\hgqt\run.pyo", line 56, in dispatch
  File "tortoisehg\hgqt\run.pyo", line 247, in _runcatch
  File "tortoisehg\hgqt\run.pyo", line 310, in runcommand
  File "mercurial\extensions.pyo", line 104, in loadall
  File "C:\Program Files (x86)\Kiln Client\kbfiles\bfsetup.py", line 1010, in uisetup
  File "mercurial\extensions.pyo", line 186, in wrapfunction
AttributeError: 'module' object has no attribute 'bail_if_changed'

Comments (2)

  1. Log in to comment