P4Merge: file always marked as resolved

Issue #2415 resolved
Daniel Sundberg
created an issue

When I merge a file using P4Merge as my merge tool, the file is always marked as resolved even though I don't save the result in P4Merge.

This might be the expected behavior, but for example when using P4Merge from Visual Studio (TFS source control) exist saving changes in P4Merge does not mark the file as being resolved...

Comments (7)

  1. Daniel Sundberg reporter

    Tried this again and now the merge tool is never displayed, the file is however marked as resolved, seems like the tool is automatically selecting "mercurial auto resolve".

    I have also changed back to kdiff3, same result.

    Upgraded to 2.7, same result. Running Windows 7, 64 bit.

    Could this be solved by uninstall/reinstall?

  2. Steve Borho

    you have to un-resolve the file before it can be re-resolved, the resolve state is tracked by Mercurial.

    If p4merge is not returning a non-zero error code when it exits without completion, then we'll have to ask the user if the merge was successful or not when there were no changes. You can try this locally by adding these two lines to your Mercurial.ini file:

    [merge-tools] p4merge.checkchanged = True

  3. Daniel Sundberg reporter

    Thanks, your solution makes this work as I expect it to.

    However, this flag was hidden very deep in the documentation, even if I could have found it in the docs I might never have understood that it applies to p4 merge.

    My other problem with the merge tool seem to have gone away, or perhaps it was related to a specific local repository.

    Resolving the issue if my account can do that.

  4. Log in to comment