remote: The system cannot find the path specified after upgrading to 2.0

Issue #243 resolved
Anonymous created an issue


I've upgraded TortoiseHG to v2.0, and I'm now unable to perform remote operations (push/pull), I get the following error:

{{{ remote: The system cannot find the path specified }}}

I am using ssh, if that matters, and my remote repository is located at

I reverted back to v. 1.1.9, and everything worked again.

Any advice?

Comments (6)

  1. Anonymous

    Hi Steve,

    Thanks for the suggestions, it helped me figure out what was wrong.

    I am communicating with the repository using ssh with a private key, therefore had I previously added to to mercurial.ini the following line:

    ssh="c:\Program Files (x86)\TortoiseHg\TortoisePlink.exe" -ssh -i "D:\dev\key.ppk"

    However, it seems that v2.0 x64 installer places the files by default in the 64-bit (C:\Program Files), and places TortoisePlink.exe under bin directory as well.

    I changed the ini file to reflect the new path, and everything worked.

    Perhaps it can be noted somewhere? This is somewhat a breaking change, I think...

  2. Michael Wolfe


    Excellent work on the 2.0 release! I second Igal's sentiments, though. This one had me baffled as well. I came close to going back to the 1.x version as a result.

    I think it is worth adding a line to the 2.0 release notes pointing out that the default location for TortoisePlink has changed and that the user's Mercurial.ini may need to be updated.

    It's been so long since I've had to make changes to my global mercurial.ini, I'd half-forgotten that I had those settings there. Also, the new output log does not show the call to TortoisePlink.exe. This makes sense because you don't need to specify it at the command line. However, it does make debugging the problem harder. Which in turn means including a line in the release notes is more important (in my opinion).

    Keep up the great work!


  3. Steve Borho

    This was in the release notes.

    You really don't need to specify the full path to TortoisePlink, it has always been in the %PATH%.

    2.0.1 will remove the bin/ folder so TortoisePlink will be in the PF/TortoiseHg root.

  4. Log in to comment