cmdserver: timed out while reading

Issue #3947 closed
Mariska Hoogenboom
created an issue

I've seen several of these errors "cmdserver: timed out while reading..." today, when I tried to commit my code using an in-process Python hook. After I restarted TortoiseHG twice (!), it worked ok again. It seemed to hang on ui.promptchoice. Not sure what triggered it.

Environment: Windows 7, 64-bit TortoiseHG 3.1.2 in-process Python commithook, which is interactive (ui.promptchoice). Extensions: eol mercurial_keyring 0.6.2 (in commit hook) jira-python 0.32 (in commit hook)

Cannot run the hook as a python command, as t is not interactive in that case.

Comments (11)

  1. Mariska Hoogenboom reporter

    I've got another one of these messages when I try to clone a repository from the server hg clone --verbose https://mercurial.ccv.local/cm_tools D:\HG\cm_tools

    cmdserver: timed out waiting for messages.

    TortoiseHG 3.1.2 on Windows 7-64 Extensions: mercurial_keyring, eol

    When I run the same command via commandline, it asks for my password. I cannot get tortoiseHG working, even though I set the password via the commandline. I expect it still wants to prompt me with a password or other message. Via commandline, the tortoiseHG hg is used.

  2. Mariska Hoogenboom reporter

    On this particular machine (laptop) it is repeated with this version of TortoiseHG. I didn't have this issue with the previous version. Even after re-installation TortoiseHG 3.1.2, I get this message. If I start hg server manually, after approx 9 to 10 sec, I get below response. D:\HG>hg serve --cmdserver pipe o 5capabilities: getencoding runcommand encoding: cp1252

    Note that I still get the same error when I try a pull, push, clone (or any other hg command) from tortoisehg.

  3. Yuya Nishihara

    Do you have an idea why it is so slow?

    It's easy to change the timeout to 10 (or even 30) secs, but it shouldn't take so long to start hg process. On my laptop, it's about 100msec.

  4. Mariska Hoogenboom reporter

    All tools start slow on this laptop. I expect some faulty network configuration somewhere, but have not found the cause yet. How can I change the timeout for cmdserver in tortoisehg? I cannot find the option.

  5. Yuya Nishihara

    cmdcore: relax the default IPC timeout (refs #3947)

    It was set to 5sec at ac9541282dbc so corruption on IPC channel could be detected instantly. Since then, the command server got better to protect its IPC channels from being damaged by extensions or hooks. So, this patch relaxes the timeout in case the command-server process is actually stalled over 5sec.

    → <<cset e17b48c98248>>

  6. Log in to comment