Overview

HTTPS SSH
Qt5Gtk2 - GTK+2.0 integration plugins for Qt5

Official home page: https://bitbucket.org/trialuser02/qt5gtk2

Requirements:

- GNU Linux or FreeBSD
- qtbase >= 5.7.0 (with private headers)
- GTK+ 2.0
- libX11

Installation:

qmake
make
make install (under root)

To change default installation root you should run the following
command:

make install INSTALL_ROOT="custom root"

Add line 'export QT_QPA_PLATFORMTHEME=qt5gtk2' to ~/.profile and re-login.
Alternatively, create the file /etc/X11/Xsession.d/100-qt5gtk2 with
the following line:

export QT_QPA_PLATFORMTHEME=qt5gtk2

Now restart X11 server to take the changes effect.

Files and directories:

libqt5gtk2.so - GTK+2.0 platform plugin
libqt5gtk2-style.so - GTK+2.0 style plugin

Attention!
Environment variable QT_STYLE_OVERRIDE should be removed before usage.