Cannot find modules rest and rest-extras

Issue #10 open
sattellite
created an issue

Hello. I tried to install pino3, but regularly pops up an error during configuration.

{{{ -- checking for module 'rest-0.6 >= 0.6' -- package 'rest-0.6 >= 0.6' not found CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal) CMakeLists.txt:62 (pkg_check_modules)

-- checking for module 'rest-extras-0.6 >= 0.6' -- package 'rest-extras-0.6 >= 0.6' not found CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal) CMakeLists.txt:63 (pkg_check_modules) }}}

Now I have installed version of vala 0.9.3. Tried to install the following versions 0.7.10, 0.8.1, 0.9.3, 0.9.8, 0.10.0, 0.10.1, 0.11.0, 0.11.1 and 0.11.2. Everywhere one and the same error that can not find the modules rest and rest-extras.

But these modules are in /usr/share/vala/vapi/

Files /usr/share/vala/vapi/rest{,-extras}-0.6.{vapi, deps} exist.

I have tried to update the cmake, but it did not help.

My distro is Gentoo ~~amd64

Comments (13)

  1. Anonymous

    I'm having the same issue. I was trying to build it for a Debian package and got this:

    --   found webkit-1.0 , version 1.2.5
    -- checking for module 'unique-1.0 >= 1.0'
    --   found unique-1.0 , version 1.1.6
    -- checking for module 'gtkspell-2.0 >= 2.0'
    --   found gtkspell-2.0 , version 2.0.16
    -- checking for module 'rest-0.6 >= 0.6'
    --   package 'rest-0.6 >= 0.6' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:266 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
      CMakeLists.txt:62 (pkg_check_modules)
    
    
    -- checking for module 'rest-extras-0.6 >= 0.6'
    --   package 'rest-extras-0.6 >= 0.6' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:266 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
      CMakeLists.txt:63 (pkg_check_modules)
    

    I installed in my chroot librest-0.7-0, librest-dev, librest-extras-0.7-0, librest-extras-dev but the installer didn't found them.

  2. Anonymous

    Hi,

    It seems the problem is more complex than simply dropping the dependency (btw, it should be updated to rest >= 06 && << 0.7).

    I have built rest 0.6 packages in Debian sid, but the build still fails:

    error: rest-0.6 not found in specified Vala API directories or GObject-Introspection GIR directories
    error: rest-extras-0.6 not found in specified Vala API directories or GObject-Introspection GIR directories
    

    This is using libgirepository1.0-0_0.6.14 and vala 0.8 (Debian sid).

    With vala 0.10, I get the errors described in #11

    Cheers, Julien

  3. Anonymous

    same here. I even installed rest-0.7. No success. Hope Pino release a deb package for this version.

  4. Anonymous

    even compiling in launchpad for precise it give error: checking for module 'rest-0.7 >= 0.7.10' -- package 'rest-0.7 >= 0.7.10' not found

    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:266 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal) CMakeLists.txt:62 (pkg_check_modules)

    -- libindicate not found, support disabled... -- Configuring incomplete, errors occurred! dh_auto_configure: cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_EXE_LINKER_FLAGS=-Wl,--as-needed returned exit code 1 make[1]: * [override_dh_auto_configure] Error 2 make[1]: Leaving directory `/build/buildd/pino-0.3' make: * [build] Error 2 dpkg-buildpackage: error: debian/rules build gave error exit status 2

  5. Log in to comment