Support recent versions of Mercurial

#2 Merged at 0041792
Repository
piro_or
Branch
support-mercurial-4.9.1
Repository
troter
Branch
default
Author
  1. Hiroshi “Piro” YUKI
Reviewers
Description

I’ve seen some errors when I’ve tried to use this extension with the Mercurial 4.9.1. These changes should make this extension compatible to recent versions of Mercurial. How about this?

Tested environments:

  • Mercurial 4.5.3 on Ubuntu 18.04.2 LTS on WSL (Windows 10)
  • Mercurial 4.9.1 on Windows 10

Comments (2)

  1. Takumi IINO repo owner

    Thank you for your pull request.
    Looks goods.

    Memo:
    mercurial.register.command was introduce at 4.3.
    mercurial.util.binary was dropped at 4.7.
    mercurial.utils.stringutil.binary was introduce at 4.6.