Post function "TTS - Reset SLA"

Issue #166 closed
Markus Hein
created an issue

We use JIRA (with agile) version v6.4.6 and your plugin in version 5.9.0. (the release information for 5.10.0 seem not regarding my actual problem)

I have some troubles with the workflow post function “TTS - Reset SLA”: We are using a simple workflow for bugs: supp_20160225a.JPG

The transitions from New and Reopen to In Work are called “Start Progress”. From In work to Resolved is called “Resolve” and from Resolved or closed to Reopen are called “Reopen”. Status “Resolved” means, that the issue is going back to the customer, who should move it to “closed” after approval (or to Reopen if necessary).

And for this wf we have two SLA definitions: a. From New or Reopen to In Work (first response time) b. From In Work to Resolved (“multiple transitions” is checked) – this is the sla time for resolution… with a pause for status Customer Action and New. This means, that the sla time for the resolution starts after the first respond – that what we want.

So far, everything works fine after the first run. Now I added the post function “TTS-Reset SLA” for “All SLAs” to the transition “Reopen”, mentioned, that all SLA-values will be reset to zero and the complete process would start again… But I got a very interesting result – reproducible:

When the issue is in status Resolved and I press “Reopen”, the “Working Duration” of SLA a. (first response time) starts again from 0s  okay. The working duration and the Pause Duration of SLA b. are still on the last values !? When I refresh the browser, I get the information from JIRA, that the issue was updated now !?  Why is there an update during the first browser refresh after the transition?? Everything seems okay (besides the old values for SLA b.) Now I press “Start Progress”: The Working Duration of a. stops at the last value and the value of the Working Duration of SLA b. is continuing !? After a new browser refresh the Working Duration of SLA a. has the value 0 (zero) !?!? And the Working duration of SLA b. is still continuing (also the Pause Duration of b. is still the same)  I thought the reset in the post function (during Reopen) should cause, that ALL SLA-time starts from 0s again, but: supp_20160225b.JPG

Is there anything wrong with my definitions, or is there a bug in TTS? It seems to me, that the post function stops working after the first hit and does not reset all SLA’s…

Thank’s in advance!

Comments (14)

  1. Tuncay Senturk repo owner

    Hi Markus,

    Sorry for the delay, I have been working on this for a couple of hours, also reproduced.
    My bad, I could not recognise early, the thing is you can not reset completed SLAs.
    For your multi-transitioned SLA (the one from In Work to Resolved) was completed, that's why it is not reset with post function.
    If you define SLA from 'In Work' to 'Closed' and add post function to Reopen transition from Resolved status, it should work.

  2. Markus Hein reporter

    Hi Tuncay, the Information: "can not reset completed SLAs" will cause some following issues/questions: 1. this would mean, that the first SLA (from "New" or "Reopen" to "In work" can't be reset with transition "reopen" from Status "Resolved" or ""Closed". 2. I will have the same Problem, when an issue has reached status "Closed" and has to be reopened. Also in this case all SLAs must be reset (have to start again from zero).

    How should we solve these issues?

  3. Tuncay Senturk repo owner

    Hi Markus,

    You're right for first question, that's a bug that I noted down by the help of this issue (bug for only one transitioned SLAs), and for your latter question if you define SLA with 'Closed' target status, you can not reset, but if you define with 'Resolved' target status, you can reset within Resolved status.

  4. Markus Hein reporter

    Hi Tunkay, sorry, I do not understand the last part "but if you define with 'Resolved' target status, you can reset within Resolved status": It seems to me, that this is in conflict with your previous statement, that "can not reset completed SLAs". Please explain...

  5. Tuncay Senturk repo owner

    Sorry for misunderstanding, my bad, I totally wrote wrong.

    Assume you have TTS - Reset SLA post function in Reopen transition from Resolved to Reopened
    - If you define SLA with 'Closed' target status, and reopen in "Resolved" status, SLA is reset,
    - If you define with 'Resolved' target status, and reopen in 'Resolved' status, SLA is not reset

    Anyway, I'm working on resetting on completed SLAs as well, but I need to analyse it more carefully (it can have side effects to clients that will not want this, may be it can be configurable) and make my all tests run.

    Just gimme some time please

    Tuncay

  6. Markus Hein reporter

    Hallo Tuncay,

    thank you for the changes. The reset of the "Pause Duration" works fine now. But after the reset I have still two Problems:

    1. both SLA's start with their countdown - although the second one should start later, when the issue is moved in Status "In work" (this is the sla start).

    2. Still only one "Working Duration" is reset in the "SLA Overview": the SLA which realy starts with the Status "Reopen" was not reset. See the screenshot, taken 52 seconds after Transition "Reopen" (where the TTS - Reset SLA is included): TTS_20160304a.JPG

    I expected for "sla-RRT3a" 52s and for "sla-RRT3b" 0s.

    Thanks in advance, Markus

  7. Log in to comment