Issue #241 resolved
KasyanovD created an issue

Hello!

Jira version: v6.3.12
Time_TO_ SLA: 5.19.0

TimeZone in our reports is shifted by 1 hour.
My default time zone +3.
Example:
Time in task:
timezone-2.jpg

Time in Report SLA:
timezone-1.jpg

How fix this problem?

Comments (13)

  1. Tuncay Senturk repo owner

    Hi Kasyanov,

    Sorry for the delay.
    SLA Report displays the exact dates from database, and all dates are persisted by JIRA servers. Could you please check following steps?
    - Is there any time difference between your JIRA server and database server?
    - How do you see those values if you run the below command?

    select * from "AO_C5D949_TTS_ISSUE_SLA" where "ISSUE_KEY" = 'ST-379'
    

    We do not do anything with timezone, just hit database and display the exact value.
    Regards
    Tuncay

  2. KasyanovD reporter

    Applications Jira and Mysql are on the same server.
    Querying the database shows the time of the report sla:

    Screenshot_3.jpg

  3. Tuncay Senturk repo owner

    Hi Kasyanov,

    Could you please try to re-generate SLA data for a single issue and see whether it changes the date?

    • Go to JIRA Admin > Add-ons > Time to SLA Menu and click on 'SLA for existing issues'
    • type JQL as below
    issuekey = 'ST-379'
    
    • Hit Generate button and see if it changes

    Thanks

  4. Tuncay Senturk repo owner

    Can you please attach
    - SLA definition dialog screenshot
    - ST-379's issue main view All tab screenshot?

    Thanks

  5. KasyanovD reporter
    • ST-379's issue main view All tab screenshot?

    Screenshot_14.jpg

    • SLA definition dialog screenshot
      Unfortunately I do not understand you. clarify please
  6. Tuncay Senturk repo owner

    SLA definition dialog is the pop up when you click on the SLA definition. I need to see your SLA definition (origin/target status, JQL, ..)

    Thanks

  7. Tuncay Senturk repo owner

    Hello,

    And the result for below SQL:

    select created from jiraissue where issuenum = 379 and project = (select project_id from project_key where project_key='ST')
    
  8. Tuncay Senturk repo owner

    Hi Kasyanov,

    No need to respond to my prior comment. Finally I am able to reproduce it.

    The bug will be fixed ASAP.

    Thanks for all your cooperation,
    Tuncay

  9. Tuncay Senturk repo owner

    Hi Kasyanov,

    This issue has been fixed with the latest release.

    Thanks for the feedback.

    Regards
    Tuncay

  10. Log in to comment