I get a 500 when trying to generate an SLA Report

Issue #256 resolved
Jasper Knops created an issue

I go to JIRA Administration > Add-ons > Time To SLA Plugin > SLA Report to generate a report and fill in the form: Filter: Task Project (containing all issues of project Task Project) SLA status: all * Working Duration: Human readable formatted

When I press Next I get a 500 error. See Attachment The error does not occur when I select any other option for SLA status.

Comments (10)

  1. Tuncay Senturk repo owner
    • changed status to open

    Hi Jasper,

    Thanks for the feedback.
    We reproduced it and we will have a hot fix ASAP.

    Regards
    Tuncay

  2. Eunice Mora

    ![Hello. I am evaluating version 5.20.0 (JIRA 6.4.6) and also see the 500 error when "SLA Status: ALL". It seems the problem is not resolved and I don't get any error messages in the JIRA logs.

    If I change "SLA Status: STILL" then the report shows the record I recently opened. If I change "SLA Status: EXCEED" then the report page is shown, but it is empty. I have 2 records that are overdue, yet they are not shown in the report. See pictures.](https://bitbucket.org/repo/nxaa7j/images/40856349-sla_report_empty.png)

  3. Tuncay Senturk repo owner

    Hi Eunice,

    Unfortunately, the problem has not been resolved for TTS versions that are compatible with JIRA 6.x
    It will be launched soon.

    Tuncay

  4. Thomas Fick

    Hi Tuncay,

    will you post an update here once the version compatible with JIRA 6.x is available? Or is there another ticket to watch since this one is "resolved" already?

    Thanks, Thomas

  5. Tuncay Senturk repo owner

    Hi Thomas,

    I reopened the ticket and I will be resolving this after the release.
    Regards

  6. Log in to comment