Pull requests

#42 Declined
Repository
ngkabra ngkabra
Branch
default
Repository
ubernostrum ubernostrum
Branch
default

Make 'django_get_version' work with django-1.4

Author
  1. Navin Kabra
Reviewers
Description

In django-1.5+, the version number is in django.utils.version, however in django-1.4 and earlier the version number is in django.version. This commit ensures that the code works with older versions.

Comments (3)

  1. Matheus dos Santos Lima

    This setup.py don't work wich "pip install -r requirements.txt" when "django" and "django-registration" are in the same "requirements.txt"

    This line:

    from django.utils.version import get_version as django_get_version
    

    Assumes that Django already installed.