Commits

varialus committed 4170ec7 Draft

Fix a few dependency errors.

Comments (0)

Files changed (7)

enhanced/java/branches/java6/INSTALL

+BUILD FAILED
+/home/user/dissonance/enhanced/java/branches/java6/build.xml:480: The following error occurred while executing this line:
+/home/user/dissonance/enhanced/java/branches/java6/classlib/build.xml:137: The following error occurred while executing this line:
+/home/user/dissonance/enhanced/java/branches/java6/target/hdk/build/ant/properties.xml:477: The Eclipse compiler class for Ant could not be found. Please place the ECJ JAR in ANT_HOME/lib.
+The JAR can be downloaded directly from eclipse.org or copied from target/depends/jars/ecj_3.x folder after the fetch-depends target for jdktools has been run.
+Alternatively, you can switch to another compiler, e.g. specify '-Dhy.javac.compiler=modern' for classic javac.
+
+cp target/depends/jars/ecj_3.7.2/ecj-3.7.2.jar /usr/share/ant/lib/

enhanced/java/branches/java6/classlib/depends/oss/README.txt

 
 
 
-ZLIB version 1.2.3
+ZLIB version 1.2.7
 ------------------
-zlib is a freely available compression library. The file zlib_1.2.3.zip
-contains almost the original source for version 1.2.3 as downloaded from the
+zlib is a freely available compression library. The file zlib_1.2.7.zip
+contains almost the original source for version 1.2.7 as downloaded from the
 zlib home page. So as not to cause confusion with the makefile developed for
-this original code contribution the original Makefile from zlib 1.2.3 has been
+this original code contribution the original Makefile from zlib 1.2.7 has been
 renamed Makefile.orig.  The original /contrib directory has been removed.
 
 The official zlib home page is located at http://www.gzip.org/zlib

enhanced/java/branches/java6/classlib/modules/archive/make/depends.properties

 
 hy.depends=depends
 
-# ZLIB, version 1.2.5 or above
+# ZLIB, version 1.2.7 or above
 # http://www.zlib.net/
-zlib.ver=1.2.5
-zlib.md5=c735eab2d659a96e5a594c9e8541ad63
+zlib.ver=1.2.7
+zlib.md5=60df6a37c56e7c1366cca812414f7b85
 zlib.basename=zlib-${zlib.ver}
 zlib.dir=${hy.depends}/oss/${zlib.basename}
 zlib.tarname=zlib-${zlib.ver}.tar.gz

enhanced/java/branches/java6/classlib/modules/script/make/depends.properties

 # limitations under the License.
 
 depends.jars=${depends.dir}/jars
-apache.base=http://www.apache.org/dist
+apache.base=http://archive.apache.org/dist
 bsf.base=${apache.base}/jakarta/bsf/binaries
 
 bsf.version=3.0

enhanced/java/branches/java6/classlib/modules/x-tools/make/depends.properties

 
 depends.jars=${depends.dir}/jars
 eclipse.base=http://download.eclipse.org/eclipse/downloads/drops
-ecj.ver=3.6.1
+ecj.ver=3.7.2
 ecj.dir=${depends.jars}/ecj_${ecj.ver}
 ecj.jar=${ecj.dir}/ecj-${ecj.ver}.jar
-ecj.url=${eclipse.base}/R-${ecj.ver}-201009090800/ecj-${ecj.ver}.jar
-ecj.md5=448c6e65234fc61624e14b0964d75bd9
+ecj.url=${eclipse.base}/R-${ecj.ver}-201202080800/ecj-${ecj.ver}.jar
+ecj.md5=b04ecb4047deed7347188825a062d30e

enhanced/java/branches/java6/classlib/modules/xmlsec/make/depends.properties

 xmlsec.basename=xmlsec-${xmlsec.version}
 xmlsec.dir=${depends.jars}/${xmlsec.basename}
 xmlsec.zip=${xmlsec.dir}/${xmlsec.zipname}
-xmlsec.url=http://santuario.apache.org/dist/java-library/${xmlsec.zipname}
+xmlsec.url=http://archive.apache.org/dist/santuario/java-library/${xmlsec.zipname}
 xmlsec.md5=d7fa5a2233584c6e3d73b58f1dbb5cd0

enhanced/java/branches/java6/common_resources/make/depends.properties

 hamcrest-library.jar.url=${maven2.base}/org/hamcrest/hamcrest-library/1.1/hamcrest-library-1.1.jar
 hamcrest-library.jar.md5=271f78edc4333f0f44df617676e0a874
 
-ecj.jar=${depends.jars}/ecj_3.6.1/ecj-3.6.1.jar
-ecj.jar.url=${eclipse.base}/R-3.6.1-201009090800/ecj-3.6.1.jar
-ecj.jar.md5=448c6e65234fc61624e14b0964d75bd9
+ecj.jar=${depends.jars}/ecj_3.7.2/ecj-3.7.2.jar
+ecj.jar.url=${eclipse.base}/R-3.7.2-201202080800/ecj-3.7.2.jar
+ecj.jar.md5=b04ecb4047deed7347188825a062d30e
 
 # Cpptasks, version 1.0 beta 3 or above
 # http://sourceforge.net/project/showfiles.php?group_id=36177