Source

dissonance / enhanced / java / branches / java6 / INSTALL

The default branch has multiple heads

1
2
3
4
5
6
7
8
BUILD FAILED
/home/user/dissonance/enhanced/java/branches/java6/build.xml:480: The following error occurred while executing this line:
/home/user/dissonance/enhanced/java/branches/java6/classlib/build.xml:137: The following error occurred while executing this line:
/home/user/dissonance/enhanced/java/branches/java6/target/hdk/build/ant/properties.xml:477: The Eclipse compiler class for Ant could not be found. Please place the ECJ JAR in ANT_HOME/lib.
The JAR can be downloaded directly from eclipse.org or copied from target/depends/jars/ecj_3.x folder after the fetch-depends target for jdktools has been run.
Alternatively, you can switch to another compiler, e.g. specify '-Dhy.javac.compiler=modern' for classic javac.

cp target/depends/jars/ecj_3.7.2/ecj-3.7.2.jar /usr/share/ant/lib/