Commits

Jason R. Coombs committed ee23427

Use compatible skipIf

  • Participants
  • Parent commits 466510a

Comments (0)

Files changed (1)

File setuptools/tests/test_dist_info.py

         assert versioned.version == '2.718' # from filename
         assert unversioned.version == '0.3' # from METADATA
 
-    @unittest.skipIf('markerlib' not in globals(),
-                     "install markerlib to test conditional dependencies")
+    @skipIf('markerlib' not in globals(),
+        "install markerlib to test conditional dependencies")
     def test_conditional_dependencies(self):
         requires = [pkg_resources.Requirement.parse('splort==4'),
                     pkg_resources.Requirement.parse('quux>=1.1')]