QA from Gentoo portage for libgap-4.5.7.p2

Issue #2 resolved
François Bissey
created an issue

Hi,

I am just making an ebuild for 4.5.7.p2 in the sage-on-gentoo overlay and portage gave me the following message after the compilation: * QA Notice: Package triggers severe warnings which indicate that it * may exhibit random runtime failures. * /scratch/portage/sci-libs/libgap-4.5.7_p2/work/libgap-4.5.7.p2/src/src/libgap.c:154:5: warning: incompatible implicit declaration of built-in function 'printf' [enabled by default]

The message is generic and a bit exagerating in this case but libgap.c should include the stdio.h header (this is with gcc 4.6.3).

Comments (1)

  1. Log in to comment