update spkg building (docs etc) to the new package structure

Issue #4 resolved
Dmitrii Pasechnik
created an issue

Currently following the instructions in README gives you libgap-.spkg. This is obsolete. libgap-.tar is also created, but it's not clear if this is the right thing to use...