Problem with Boost.Python

Issue #92 new
Ferhat Aram
created an issue

Hello guys,

When I try to compile Vera++ via Cmake on my Windows system, i get the following error code:

CMake Error at C:/Program Files/CMake/share/cmake-3.8/Modules/FindBoost.cmake:1842 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.64.0

  Boost include path: C:/boost/boost_1_64_0

  Could not find the following static Boost libraries:

          boost_python

  Some (but not all) of the required Boost libraries were found.  You may
  need to install these additional Boost libraries.  Alternatively, set
  BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
  to the location of Boost.
Call Stack (most recent call first):
  src/boost.cmake:25 (find_package)
  src/CMakeLists.txt:16 (include)

I already installed boost.python seperatley with "bjam --with-python", so there should be no problem normally. Sadly I'm not really firm with Cmake or Boost. I think this might be really easy to solve problem, but I have absolutley no clue how to solve this issue.

Does anyone of you have an idea, how to fix that problem?

Comments (9)

  1. Vincent Hobeïka

    In fact my appveyor setup doesn't install boost-python. It is provided by default by the appveyor VMs. So I don't know exactly how you should install this one.

    For me you are doing quite the right thing with bjam. Maybe it's just some missing environment variable. You may want to try to setup the path manually into cmake like I am doing in : appveyorNightly.yml

    BOOST_ROOT: C:\Libraries\boost_1_64_0
    BOOST_LIBRARYDIR: C:\Libraries\boost_1_64_0\lib32-msvc-14.0
    

    or if you are building in 64 bits:

    BOOST_ROOT: C:\Libraries\boost_1_64_0
    BOOST_LIBRARYDIR: C:\Libraries\boost_1_64_0\lib64-msvc-14.0
    

    Best of luck!

  2. Ferhat Aram reporter

    Thanks for your help. I just build it without the Python module and going to learn TCL for creating new rules.

    But now I've got another Problem. I've build Vera++ with Cmake and then tried to build the INSTALL package in VS17. But whenever I try to build it, i get the following problem:

    Unbenannt.PNG

    Any suggestions here? I really need help, it's really frustrating that I can't install it :/

  3. Ferhat Aram reporter

    Hello,

    Sorry for the late response, I had holidays :)

    I just manually downloaded the file and copied in the folder and it worked. Thanks. But now I got the next error. Hopefully you have an idea how to fix it:

    Vera++.PNG

    Thank you very much.

  4. Vincent Hobeïka

    Oh ok you have boost installed. Maybe you may want to use the flag VERA_USE_SYSTEM_BOOST and set it to ON so vera++ will use your boost installation to build.

    Hope that helps!

  5. Ferhat Aram reporter

    So I just put it on, but now CMake somehow doesnt find boost. I already set the PREFIX/bin in PATH and it still doesnt work. Any idea why that could be? It can't detect boost.

    Is there another way to work with the code and build it? I've stucked with the installation since three weeks :/

  6. Log in to comment