Prefer the newest version of Lua before specifically looking for version 5.1

#7 Merged at f785abf
Repository
nocnokneo
Branch
find_newer_lua_versions
Repository
verateam
Branch
master
Author
  1. Taylor Braun-Jones
Reviewers
Description

This fixes building on Fedora > 19 which come with lua-5.2 (but still works with Fedora 19 which comes with lua-5.1)

Here's an example of a failing build without this patch: https://kojipkgs.fedoraproject.org//work/tasks/5559/9415559/build.log

Code Quality

Comments (2)

  1. Gaƫtan Lehmann

    Unfortunately the lua version depends a lot on the version used to build luabind, and the last stable version of luabind does not work with lua 5.2. This is why the version was restricted to lua 5.1.

    Could you tell us what is the version used by luabind in fedora?