Release 0.9.0 requires python >= 3.6

Create issue
Issue #22 resolved
Cédric Krier created an issue

The setup.py does not set python_requires='>=3.6' so when installing with old Python the version 0.9.0 is picked but then using it failed because of type annotation.
It will be great to add this metadata on release 0.9.0 if possible or to make a bugfix release and hide this version.

Comments (4)

  1. wmj repo owner

    Thank you! I knew I was forgetting something important in the transition. Release a patched version as 0.9.1. Version 0.9.0 has been set as yanked.

  2. Log in to comment