Issue #1 resolved

Not in scope: type constructor or class `YesodExample'

nomeata
created an issue

Hi,

version 1.2.1 does not build with recent versions of yesod. Please consider upgrading to 1.2.2, and please also consider to add upper bounds to your build dependencies to save your users from stumbling over failed builds.

See https://buildd.debian.org/status/fetch.php?pkg=haskell-yesod-auth-account&arch=i386&ver=1.2.1-1&stamp=1376007119 for a full build log.

Thanks, Joachim

Comments (4)

  1. John Lenz repo owner

    It is the other way around. From your build log, you are trying to use yesod-test-0.3.5 which is an old version. The new version of yesod-test is 1.2.1 and the code compiles fine against it. I will add a lower bound on yesod-test so your build doesn't pick up the old version and instead compiles against the new version

  2. John Lenz repo owner

    I uploaded 1.2.2 to hackage with this fix. I also just tested it with the latest of all the dependencies on hackage.

    As of today there is a problem with cipher-aes: a new version was uploaded today and some of the yesod dependencies like tls-extra have an upper bound which prevent the use of the new version. The error ends up in a build failure in an old version of cryptocipher that cabal decided to install. The bug seems to be in cabal that it can't find the correct set of dependencies. I fixed it via "cabal install cipher-aes-0.1.8 yesod-auth". We don't even depend on cipher-aes so not sure how to fix it in this package.

  3. Log in to comment