Source

ess / texi / requires.texi

Full commit
ESS version 5.1.n (n >= 2) works best with either GNU Emacs version 20.3 or higher, or
XEmacs version 20.0 or higher.  It has been most thoroughly tested with:

@itemize @bullet
@item S-PLUS versions 3.3, 3.4, 4.5, 5.0, 5.1, 6
@item R versions >=0.49
@item S4
@item SAS 6.x, 7.x, 8.x
@item BUGS 0.5 or 0.603
@item Stata >=6.0
@item XLispStat versions >=3.50
@end itemize

on the following platforms

@itemize @bullet
@item Solaris/SunOS (all)
@item SGI (all)
@item Linux (S-PLUS 5.0, 5.1, R, XLispStat, S4, Stata 6.0)
@item Microsoft Windows 95/98/NT/2000 (SPLUS 4.5 and 2000)
@item Apple Mac OS (SAS for OS 9 and X11 R for OS X)
@end itemize

with the following versions of emacs

@itemize @bullet
@item GNU Emacs 20.3, 20.4, 20.5, 20.6, 20.7, 21.1
@item XEmacs 20.0, 20.4, 21.0, 21.1.13, 21.1.14, 21.4 
@item XEmacs 19.14, 19.16 and GNU Emacs 19.28, 19.29, 19.34 (see footnote)
@end itemize

@footnote{Note that you must have "custom" support.  It is available @
@uref{http://www.dina.kvl.dk/~abraham/custom/}  These releases of emacs are no
longer supported, so an upgrade is recommended if you plan to use ESS.  
This is not to say that ESS will not work, but it will be up to the user 
to set it up on their own.  If you have GNU Emacs 19.29, you @emph{may} 
get it to work after unpacking @file{19.29.tar.gz}, see the installation 
instructions.}