Commits

Anonymous committed 1812d9e

Give a nicer error message if lacking Unicode coverage, fsf-compat-unicode.el

  • Participants
  • Parent commits d05ab65

Comments (0)

Files changed (2)

+2009-09-26  Aidan Kehoe  <kehoea@parhasard.net>
+
+	* fsf-compat-unicode.el: 
+	Give a nicer error message if this XEmacs doesn't have the Unicode
+	coverage necessary for this file.
+	(fsf-compat-init-mule-unicode-charsets): 
+	Add an autoload cookie for this.
+
 2009-09-15  Norbert Koch  <viteno@xemacs.org>
 
 	* Makefile (VERSION): XEmacs package 1.55 released.

File fsf-compat-unicode.el

 
 ;; Check at runtime that the Unicode support is available, and that its
 ;; coverage is good enough.
-(unless (and (fboundp 'encode-char)
+(unless (and (fboundp 'encode-char) (decode-char 'ucs #x31C)
              (eq #x31C (encode-char (decode-char 'ucs #x31C) 'ucs)))
   (error 'unimplemented
-	 "Unicode support needed is not available in your XEmacs."))
+	 "Unicode support or coverage needed not available"))
 
 ;; For redisplay of these character sets, provide a CCL program to address
 ;; iso10646-1 X11 fonts.
       pre-existing))
   "CCL program required by `fsf-compat-init-mule-unicode-charsets'.")
 
+;;;###autoload
 (defun fsf-compat-init-mule-unicode-charsets ()
   "Make some Mule character sets that the FSF uses available in XEmacs.