1. Kirill Simonov
  2. libyaml
  3. Issues
Issue #4 new

Supported YAML version is unspecified

e_d_a_m
created an issue

It isn't clear which version of the YAML specification this library (and, therefore, also PyYAML) support. On the YAML website, libyaml and PyYAML are listed as supporting version 1.1, but it should be explicitly and officially stated in the project somewhere (perhaps the README?).

Comments (1)

  1. Morel Bérenger

    I think the best would be to have a function/macro returning the YAML version(s?) supported by the library. The difference is that this way, it would be possible for softwares to check if the streams they are parsing are old enough.

  2. Log in to comment