Cannot create more than 3 devices

Issue #94 closed
Randy Arrasmith created an issue

fauxmoESP is pretty neat! Thanks for making this available. I am using version 3.1.0 via platformio. I have create a class to control my home office led strip and got it working easily with 1 emulated device. So I quickly add 2 more devices that control the same led strip but different modes: change to blue lights and run an effect (Random twinkle). Also working great! When I add a forth (or more) devices, alexa can no longer detect any of the emulated Hue devices. Comment out the additional addDevice calls and they are found again. 100% repeatable.

I tried enabling debug but am not using a serial output on the 8266. Actually I have fauzmoESP working via ESPHOME (platformio based) which is really quite cool. I also tried, on a whim, increasing Rx time from 3 to 5 but that didn’t have any effect (and not really sure what that does, but was hoping more devices might need a bigger value).

Any insight why 3 devices is working perfectly, detectable by alexa, etc but a forth (or more) is not working would be greatly appreciated.

Comments (5)

  1. Log in to comment