Commits

Thomas Waldmann committed b02d552

require pytest < 2.3, because pytest 2.3.x doesn't work with our test code, likely due to the fixture changes done after 2.2

Comments (0)

Files changed (1)

         'Jinja2>=2.6', # template engine
         'pygments>=1.4', # src code / text file highlighting
         'Werkzeug>=0.8.1', # wsgi toolkit
-        'pytest>=2.1', # pytest is needed by unit tests
+        'pytest>=2.1, <2.3', # pytest is needed by unit tests
+                             # note: currently 2.3.x is not compatible with our test code,
+                             # likely due to the fixtures changes.
         'pytest-pep8', # coding style checker
         'whoosh>=2.4.0', # needed for indexed search
         'sphinx>=1.1', # needed to build the docs
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.