Commits

Horst Gutmann committed 5bf6e5e

Fixes some compatibility issues with django-cms >= 2.2 et al.

Comments (0)

Files changed (2)

cmsplugin_news/forms.py

         model = News
         
     def _get_widget(self):
-        plugins = plugin_pool.get_text_enabled_plugins(placeholder=None)
+        plugins = plugin_pool.get_text_enabled_plugins(placeholder=None, page=None)
         if USE_TINYMCE and "tinymce" in settings.INSTALLED_APPS:
             from cmsplugin_news.widgets.tinymce_widget import TinyMCEEditor
             return TinyMCEEditor(installed_plugins=plugins)
         super(NewsForm, self).__init__(*args, **kwargs)
         widget = self._get_widget()
         self.fields['content'].widget = widget
-        
+        
         'Framework :: Django',
     ],
     include_package_data=True,
-    zip_safe=False,
-    install_requires=['setuptools', 'setuptools_bzr'],
+    zip_safe=False
 )