Source

iredmail / iRedMail / conf / global

Diff from to

File iRedMail/conf/global

         #   - 12.3: dartmouth
         export DISTRO_CODENAME="$(grep 'CODENAME' /etc/SuSE-release | awk '{print $3}' |tr [A-Z] [a-z])"
 
-        # Unsupported releases: 10.x, 11.x, 12.1 (asparagus).
+        # Unsupported releases: 10.x, 11.x, 12.1 (asparagus), 12.2.
         if echo "${DISTRO_VERSION}" | grep '^1[01]' &>/dev/null ; then
             export UNSUPPORTED_RELEASE='YES'
-        elif echo "${DISTRO_VERSION}" | grep '^12\.1' &>/dev/null ; then
+        elif echo "${DISTRO_VERSION}" | grep '^12.[12]' &>/dev/null ; then
             export UNSUPPORTED_RELEASE='YES'
         fi
 
     export DIR_RC_SCRIPTS='/etc/rc.d'
     export RC_CONF_LOCAL='/etc/rc.conf.local'
     export SHELL_BASH='/usr/local/bin/bash'
+
+    # Unsupported release: 5.1, 5.2.
+    if echo "${DISTRO_VERSION}" | grep '^5.[12]' &>/dev/null ; then
+        export UNSUPPORTED_RELEASE='YES'
+    fi
 else
     # Not support *BSD and other distrobutions yet.
     echo "Error: Your OS is not supported yet."