Source

iredmail / iRedMail / functions / packages.sh

Author Commit Message Labels Comments Date
Zhang Huangbin
* Add missing package on Debian/Ubuntu. * Add 'inet6 => 0' in Amavisd ldap setting to avoid ldap connection error.
Zhang Huangbin
* Enable Awstats on Ubuntu 13.10. * Fix incorrect package name on openSUSE-13.1.
Zhang Huangbin
Re-enable Cluebringer webui on Ubuntu 13.10 with libaprutil1-dbd-mysql.
Zhang Huangbin
Better support for OpenBSD 5.4: - Add missing package for ldapd backend. - Use valid log format in Awstats for built-in Apache log file. - Don't explicitly specify cyrus-sasl package flavor to avoid package conflict.
Zhang Huangbin
* Remove unused file: dialog/awstats_config.sh. * OpenBSD 5.4 support: + Enable Awstats. + Install and enable PHP module php-pdo_mysql/pgsql for Roundcube webmail. * Drop support for OpenBSD 5.3.
Zhang Huangbin
* Disable Awstats and Cluebringer webui on Ubuntu 13.10 due to package missing: libapache2-mod-auth-mysql, libapache2-mod-auth-pgsql. * Add [DEFAULT] section in Fail2ban config file: /etc/fail2ban/jail.local. Thanks Daniel Black (daniel.subs@) for the help.
Zhang Huangbin
* Decrease Cluebringer log level. * Add missing packages for Cluebringer on RHEL/CentOS while installing with remote MySQL server. * Cleanup iRedMail.tips.
Zhang Huangbin
Code cleanup.
Zhang Huangbin
Better support for installing iRedMail with remote MySQL server.
Zhang Huangbin
Enable iRedAPD plugin 'ldap_recipient_restrictions' for OpenLDAP backend by default. Code cleanup in functions/packages.sh.
Zhang Huangbin
Fix incorrect file permission of sasl lib on OpenBSD 5.3. Thanks djbahati1 <djbahati-at-gmail> for the report in our support forum.
Zhang Huangbin
Switch from Policyd-1.8 to Cluebringer on all Linux/BSD distributions.
Zhang Huangbin
Add missed package 'libapache2-mod-auth-pgsql' on Debian/Ubuntu.
Zhang Huangbin
Drop support for Gentoo.
Zhang Huangbin
Drop support for Debian 6 (squeeze).
Zhang Huangbin
Drop support for below distribution releases: + Ubuntu 12.10 + RHEL/CENTOS 5.x
Zhang Huangbin
Use EPEL yum repo on RHEL/CentOS 6 by default, but not on RHEL/CentOS 5.
Zhang Huangbin
Drop support for below releases: + OpenBSD 5.1, 5.2. + openSUSE 12.1, 12.2.
Zhang Huangbin
* Disable Dovecot expire plugin by default. * Install Fail2ban on FreeBSD. Work in progress to make it work with ipfw.
Zhang Huangbin
* Install php53 from vender official yum repo on RHEL/CentOS 5. * Allow to assign mail list/alias as member of mailing list.
Zhang Huangbin
openSUSE-12.3: don't hard-code Postfix setting everytime we restart Postfix service. Stop this terrible over-design.
Zhang Huangbin
WIP: It now works on openSUSE-12.3.
Zhang Huangbin
Fixed: mod_auth_pgsql is required by cluebringer too. Thanks Ville Lamminen <ville.lamminen _at_ locactive.com> for the feedback.
Zhang Huangbin
Typo.
Zhang Huangbin
Code cleanup.
Zhang Huangbin
OpenBSD ldapd(8) now works. Still need to add ACL in /etc/ldapd.conf.
Zhang Huangbin
Install policyd (v1) on Debian 6.
Tags
0.8.3
Zhang Huangbin
It now works on Ubuntu 12.10 (quantal).
Zhang Huangbin
Drop support for openSUSE 12.1 (asparagus), please use 12.2 (mantis) instead.
Zhang Huangbin
Drop support for Ubuntu 10.04 (lucid), please use the latest LTS edition 12.04 (precise) instead.
  1. Prev
  2. 1
  3. 2
  4. 3
  5. 4
  6. Next