Freebsd can not install some ports of iredmail

Issue #109 resolved
Kiki307
created an issue

==== Required information ==== - iRedMail version (check /etc/iredmail-release): 0.9.7 beta (4b71df6) - Linux/BSD distribution name and version: fresh Freebsd 11 x64 with latest ports and updates - Store mail accounts in which backend (LDAP/MySQL/PGSQL): mariadb - Web server (Apache or Nginx): apache - Manage mail accounts with iRedAdmin-Pro? no - [IMPORTANT] Related original log or error message is required if you're experiencing an issue. ==== yes, it is not iredmail bug, but iredmail not install on fresh updated freebsd i found some information about this http://www.mail-archive.com/freebsd-ports@freebsd.org/msg74725.html http://www.mail-archive.com/freebsd-ports@freebsd.org/msg74736.html http://www.mail-archive.com/freebsd-ports@freebsd.org/msg74741.html http://www.mail-archive.com/freebsd-por … 74760.html

my log /usr/local/share/apr/build-1/libtool --silent --mode=link cc -O2 -pipe -I/usr/local/include -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -L/usr/local/lib/db5 -L/usr/lib -L/usr/local/lib -Wl,-rpath,/usr/local/lib -fstack-protector -o htdbm htdbm.lo passwd_common.lo -L/usr/local/lib -R/usr/local/lib -laprutil-1 -ldb-5.3 -lexpat -L/usr/local/lib -R/usr/local/lib -lapr-1 -lcrypt -lpthread -lcrypt /usr/local/share/apr/build-1/libtool --silent --mode=compile cc -I/usr/local/include -O2 -pipe -I/usr/local/include -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -DLIBICONV_PLUG -I. -I/usr/ports/www/apache24/work/httpd-2.4.26/os/unix -I/usr/ports/www/apache24/work/httpd-2.4.26/include -I/usr/local/include/apr-1 -I/usr/local/include -I/usr/local/include/db5 -I/usr/include -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/aaa -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/cache -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/core -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/database -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/filters -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/ldap -I/usr/ports/www/apache24/work/httpd-2.4.26/server -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/loggers -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/lua -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/proxy -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/session -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/ssl -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/test -I/usr/ports/www/apache24/work/httpd-2.4.26/server -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/arch/unix -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/dav/main -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/generators -I/usr/ports/www/apache24/work/httpd-2.4.26/modules/mappers -prefer-non-pic -static -c ab.c && touch ab.lo ab.c:2518:5: warning: implicit declaration of function 'SSL_CTX_set_max_proto_version' is invalid in C99 [-Wimplicit-function-declaration] SSL_CTX_set_max_proto_version(ssl_ctx, max_prot); ^ ab.c:2519:5: warning: implicit declaration of function 'SSL_CTX_set_min_proto_version' is invalid in C99 [-Wimplicit-function-declaration] SSL_CTX_set_min_proto_version(ssl_ctx, min_prot); ^ 2 warnings generated. /usr/local/share/apr/build-1/libtool --silent --mode=link cc -O2 -pipe -I/usr/local/include -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -L/usr/local/lib -lssl -lcrypto -lcrypt -lpthread -L/usr/local/lib/db5 -L/usr/lib -L/usr/local/lib -Wl,-rpath,/usr/local/lib -fstack-protector -o ab ab.lo -L/usr/local/lib -R/usr/local/lib -laprutil-1 -ldb-5.3 -lexpat -L/usr/local/lib -R/usr/local/lib -lapr-1 -lcrypt -lpthread -lm ab.o: In function main': ab.c:(.text+0xbd9): undefined reference toSSL_CTX_set_max_proto_version' ab.c:(.text+0xbea): undefined reference to `SSL_CTX_set_min_proto_version' cc: error: linker command failed with exit code 1 (use -v to see invocation) Error code 1 Stop. make[3]: stopped in /usr/ports/www/apache24/work/httpd-2.4.26/support Error code 1 Stop. make[2]: stopped in /usr/ports/www/apache24/work/httpd-2.4.26/support Error code 1 Stop. make[1]: stopped in /usr/ports/www/apache24/work/httpd-2.4.26 Error code 1 Stop. make: stopped in /usr/ports/www/apache24 << ERROR >> Port was not successfully installed, please fix it manually and then re-execute this script.

Comments (6)

  1. Log in to comment