0.9.5-1: Awstats world readable Ubuntu 16.04 (LDAP Backend)

Issue #95 resolved
Anonymous created an issue

Distribution: Ubuntu 16.04 LTS State: vanilla Webserver: Apache Backend: openLdap Release: current stable 0.9.5-1

This happened on two consecutive installations and a quick look in the Bugtracker did not show any open issues. A fresh installation with awstats enabled generates the following config and makes /awstats world readable:

cat /etc/apache2/conf-available/awstats.conf
[...]
<Directory /usr/lib/cgi-bin/>
[...]
   AuthLDAPBindDN "cn=vmail,dc=example,dc=com"
   AuthLDAPBindPassword "***"
   Require all granted
   Require valid-user
</Directory>

This bug should be reproducable on a fresh installation.

Comments (2)

  1. Log in to comment