1. zurmo
  2. zurmo
  3. Issues

Issues

Issue #315 new

AccessDeniedSecurityException when $memcacheLevelCaching = true;

Ian DeFazio
created an issue

getting

An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator.

when $memcacheLevelCaching = true;

while trying to enter Accounts or Leads

Screencast of problem http://vid.storm5.com/private/videos/LtAK67h/

Comments (25)

  1. Muhammad Shoaib

    I have been trying to replicate it on my install using 2.8.6 but couldn't get it. Here is how i did it:

    • Default install with memcache on.
    • Login as super
    • Create a new user.
    • Logout
    • Login as new user
    • Go to Accounts
    • Go to Leads

    It would help if you could provide the steps to replicate the issue. Also, would be nice if you uploaded your application.log file(clear it up before doing the test to ensure only relevant messages show up there).

  2. Ferit Demir

    Hi Muhammad Shoaib use your installation which you have already and go ahead with...

    You see at attachement my roles and groups setup

    After i created one user with the role Executive and one user Country Manager Turkey , I created some "Accounts + Contacts" related to Group Germany and some to Group Turkey. (fyi: some accounts were created before creating roles or groups)

    When i log in with the account of Country Manager Turkey i get the error: The reference id for this error is 52bd64cfd ....

    Bildschirmfoto 2015-01-13 um 09.29.49.png

    Bildschirmfoto 2015-01-13 um 09.54.34.png

    Bildschirmfoto 2015-01-13 um 09.29.29.png

  3. Ferit Demir

    This is what i get in application log

    2015/01/10 23:25:31 [error] [exception.AccessDeniedSecurityException ] exception 'AccessDeniedSecurityException' in /www/htdocs/w012bc6c/app/protected/modules/zurmo/models/SecurableItem.php:499 Stack trace:

    0 /www/htdocs/w012bc6c/app/protected/modules/zurmo/models/OwnedSecurableItem.php(506): SecurableItem->checkPermissionsHasAnyOf(1, Object(User))

    1 /www/htdocs/w012bc6c/app/protected/modules/zurmo/models/SecurableItem.php(457): OwnedSecurableItem->checkPermissionsHasAnyOf(1)

    2 /www/htdocs/w012bc6c/yii/framework/base/CComponent.php(606) : eval()'d code(1): SecurableItem->__get('account')

    3 /www/htdocs/w012bc6c/yii/framework/base/CComponent.php(606): eval()

    4 /www/htdocs/w012bc6c/app/protected/core/components/DataColumn.php(101): CComponent->evaluateExpression('ActionSecurityU...', Array)

    5 /www/htdocs/w012bc6c/yii/framework/zii/widgets/grid/CGridColumn.php(144): DataColumn->renderDataCellContent(0, Object(Contact))

    6 /www/htdocs/w012bc6c/yii/framework/zii/widgets/grid/CGridView.php(589): CGridColumn->renderDataCell(0)

    7 /www/htdocs/w012bc6c/yii/framework/zii/widgets/grid/CGridView.php(545): CGridView->renderTableRow(0)

    8 /www/htdocs/w012bc6c/yii/framework/zii/widgets/grid/CGridView.php(455): CGridView->renderTableBody()

    9 /www/htdocs/w012bc6c/yii/framework/zii/widgets/CBaseListView.php(160): CGridView->renderItems()

    10 [internal function]: CBaseListView->renderSection(Array)

    11 /www/htdocs/w012bc6c/yii/framework/zii/widgets/CBaseListView.php(143): preg_replace_callback('/{(\w+)}/', Array, '{summary}<div c...')

    12 /www/htdocs/w012bc6c/yii/framework/zii/widgets/CBaseListView.php(128): CBaseListView->renderContent()

    13 /www/htdocs/w012bc6c/yii/framework/web/CBaseController.php(173): CBaseListView->run()

    14 /www/htdocs/w012bc6c/app/protected/core/views/ListView.php(146): CBaseController->widget('application.cor...', Array)

    15 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): ListView->renderContent()

    16 /www/htdocs/w012bc6c/app/protected/core/views/GridView.php(155): View->render()

    17 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): GridView->renderContent()

    18 /www/htdocs/w012bc6c/app/protected/core/views/GridView.php(155): View->render()

    19 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): GridView->renderContent()

    20 /www/htdocs/w012bc6c/app/protected/core/views/GridView.php(155): View->render()

    21 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): GridView->renderContent()

    22 /www/htdocs/w012bc6c/app/protected/modules/zurmo/views/ZurmoDefaultView.php(54): View->render()

    23 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): ZurmoDefaultView->renderContent()

    24 /www/htdocs/w012bc6c/app/protected/core/views/PageView.php(160): View->render()

    25 /www/htdocs/w012bc6c/app/protected/core/views/View.php(88): PageView->renderContent()

    26 /www/htdocs/w012bc6c/app/protected/core/views/PageView.php(75): View->render()

    27 /www/htdocs/w012bc6c/app/protected/modules/contacts/controllers/DefaultController.php(88): PageView->render()

    28 /www/htdocs/w012bc6c/app/protected/modules/zurmo/components/ZurmoModuleController.php(61): ContactsDefaultController->actionList()

    29 /www/htdocs/w012bc6c/yii/framework/web/actions/CInlineAction.php(49): ZurmoModuleController->actionIndex()

    30 /www/htdocs/w012bc6c/yii/framework/web/CController.php(308): CInlineAction->runWithParams(Array)

    31 /www/htdocs/w012bc6c/yii/framework/web/filters/CFilterChain.php(133): CController->runAction(Object(CInlineAction))

    32 /www/htdocs/w012bc6c/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()

    33 /www/htdocs/w012bc6c/yii/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))

    34 /www/htdocs/w012bc6c/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()

    35 /www/htdocs/w012bc6c/yii/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))

    36 /www/htdocs/w012bc6c/yii/framework/web/CController.php(291): CFilterChain->run()

    37 /www/htdocs/w012bc6c/yii/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)

    38 /www/htdocs/w012bc6c/yii/framework/web/CWebApplication.php(282): CController->run('')

    39 /www/htdocs/w012bc6c/yii/framework/web/CWebApplication.php(141): CWebApplication->runController('contacts/defaul...')

    40 /www/htdocs/w012bc6c/yii/framework/base/CApplication.php(169): CWebApplication->processRequest()

    41 /www/htdocs/w012bc6c/app/protected/core/components/WebApplication.php(75): CApplication->run()

    42 /www/htdocs/w012bc6c/app/index.php(70): WebApplication->run()

    43 {main}

    REQUEST_URI=/app/index.php/contacts/default HTTP_REFERER=http:// domain /app/index.php/accounts/default

  4. Burke Allen

    Ferit, I was not suggesting this was the fix, I am very new to Zurmo, this was just the way to get around the bug temporarily, and hopefully some information for the people working on the code as to where the bug is so they can correct it. seems like a lot of people are affected by this I am running my instance of Zrumo on Google Compute Cloud with a system configuration of 1 vCPU, 3.8 GB memory, there is not a super noticeable difference in performance with $memcacheLevelCaching = false set. I am sure the smaller the system config or if running on shared host, this would have a larger impact performance.

  5. Burke Allen

    Sushil, when you say latest release, what is the version and release number you are referring to. this happens to every user that is not in the SuperUser in our system with $memcacheLevelCaching = true, and the error goes away when $memcacheLevelCaching = false

    we are running 2.8.6

  6. Sushil Meher

    I am on revision number 15838 the tip of the bleeding edge. I tried for a user who is not super user still there is no error with $memcacheLevelCaching = true.

  7. Daniel Pinzon

    similar issue,

    Clean installation of Zurmo.

    i created 5 users without rights modifications that is (everyone). login with every user and all is ok

    but....

    login with user 1 create a contact with rigths everyone. log out.

    login with any of the remaining 4 users, go to the contacts tab and crash.

    An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator. The reference id for this error is edf84ab388f841578b2ef52f18082016.

    Setting up Group Record Permissions Read from (No Set - Ad-hoc/Owner) to (All) in all modules solves the issue but lost all control of restrict access to certain groups.

    another solution is setting $memcacheLevelCaching = false; in debug.php in this way I'm facing the issue, but should be fixed to take advantage of cache rigths permisions.

    I'm running an AWS ec2 instance with LAMP stack manually installed (Apache 2.4.7),(PHP 5.5.9-1ubuntu4.9), (Mysql 5.5.43-0ubuntu0.14.04.1), all system diagnostic pass except APC (is not installed) because is not compatible with php 5.5.9 may be this is the reason of the issue. I tried to install the versions used in the demo site in order to use APC (Apache 2.2.15), (PHP 5.4.11), (Mysql 5.5.29), but it was imposible because this versions no longer exist or are supported in the official ubuntu repositories and manual installation is very painful to configure and unmaintainable.

  8. Daniel Pinzon

    APC discarded, APCu installed and enabled Opcache but still does not work with $ memcacheLevelCaching = true

    i'm back to $ memcacheLevelCaching = false;

    I'm running Zurmo 3.0.4

  9. Log in to comment