Dependency Pick List not filtering options correctly

Issue #406 new
LeewardBA created an issue

The field type of Dependency Pick List is not working correctly for the Opportunities module.

I have a dependency pick list created and working correctly in the Contacts module, however when trying to create one for opportunities, the dependency pick list is not filtering the selection options at all.

In the Contacts module - when the first selection layer of the dependency pick list is set to (None), the second layer states "First select the District" (District is the name of the pick list for the first layer).

In the Opportunities module - when the first selection layer of the dependency pick list is set to (None), the second layer states (None) as well. When you click on the second layer to select a choice, all the options are also displayed.

Please Help!

Comments (12)

  1. Gabriel Shahzad

    I just tried to recreate your issue in the live demo with a 2 level pick list and had no success replicating it. It worked flawless in the opportunities module and in the contacts module. Are you sure you set up the dependent pick list correctly?

  2. LeewardBA reporter

    Hi Gabriel,

    The dependency pick list that was originally inputted was comprised of two long pick lists. Level one had 20 options, while level two had 60 options. The dependency pick list that worked in contacts was shorter, made up of 6 options in level one, and 7 options in level two.

    Would this have anything to do with it?

  3. Gabriel Shahzad

    It shouldn't, but then again you never know.
    Could you post a screenshot of your pick list, so I could try to replicate this error?

  4. LeewardBA reporter

    Gabriel,

    Please see picture album link - http://imgur.com/a/eQ9yW

    This album has the three Zurmo elements - 2 pick lists, and 1 dependency pick list - showing in full detail. The first pick list is a collection of "types of providers" for health care (first two images). The second pick list is for the "names of service providers" of those healthcare types (next 5 images). The Dependency pick list should then be a comprehensive list of types and providers (next 5 more images). The last three images show how the dependency pick list is displayed/behaves when creating a new "Opportunity."

    Please let me know what other information i can provide. Thank you for your assistance.

  5. LeewardBA reporter

    Gabriel,

    Can you please clarify your question? If you are asking how does the malfunctioning Dependency Pick List works, that is documented in the last three pictures of the album (Pictures Titled: New Opportunity - Dependency Pick List - Selection Options (1 - 3)). Both fields show (None). When you click on either level, all the options of that corresponding pick list are displayed, regardless of what first level is selected.

    Happy to provide any other information you may need.

  6. Gabriel Shahzad

    My bad! I didn't scroll all the way down.
    So in any case your pick list looks like it is configured correctly. Only way to know if there's an issue with the length of the list is to create a new dependent pick list and add item after item and check after each addition if the error shows up or not.

  7. LeewardBA reporter

    Gabriel,

    That's the thing. If I make a new Dependency Pick list with even just 2 levels, with 1 option each, it produces the same error. I've attempted to make several different combinations of dependency pick lists with multiple levels, each with varying amounts of options, and they all show the same behavior.

    The one working dependency pick list in the Contact's module (which was created prior to the longer, non-working dependency pick list in Opportunities) is still working. I'm scared to mess with it because that may stop working too!

  8. Gabriel Shahzad

    I guess the only way to check if it is a Zurmo issue or something in your configuration is to cross check with the Zurmo demo: http://demo.zurmo.com/demos/stable/app/index.php/zurmo/default/login

    I know it's a tedious job, but try to recreate the issue there. If it is flawed there as well, then we can try to figure out what's wrong. If it's not flawed there, then you have to check on your side for any errors in your configuration.

    Also, try to use the developer tools under the administration settings. Especially the clear cache and update custom data tools. (Actually do this before spending too much time to recreate the list in the demo :^))

  9. LeewardBA reporter

    Thank you for all your help, Gabriel! Awesome advice. It's been a big bother for a couple weeks now.

    I'll work on this this week, and will report back any findings.

  10. Gabriel Shahzad

    I just hope you can sort this out and together we can find a solution to stop this from happening to other users.

  11. Log in to comment