Can't build with python 3.5

Issue #106 resolved
Luigi Baldoni
created an issue
> python3 setup.py build
Traceback (most recent call last):
  File "setup.py", line 5, in <module>
    from setuptools import setup, find_packages
  File "/usr/lib/python3.5/site-packages/setuptools/__init__.py", line 10, in <module>
    from setuptools.extern.six.moves import filter, filterfalse, map
  File "/usr/lib/python3.5/site-packages/setuptools/extern/__init__.py", line 1, in <module>
    from pkg_resources.extern import VendorImporter
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3015, in <module>
    @_call_aside
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2999, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3043, in _initialize_master_working_set
    for dist in working_set
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3043, in <genexpr>
    for dist in working_set
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2573, in activate
    declare_namespace(pkg)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2147, in declare_namespace
    _handle_ns(packageName, path_item)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2087, in _handle_ns
    _rebuild_mod_path(path, packageName, module)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2116, in _rebuild_mod_path
    orig_path.sort(key=position_in_sys_path)
AttributeError: '_NamespacePath' object has no attribute 'sort'

Comments (3)

  1. Michael Bayer repo owner

    here's what I get:

    $ /opt/python3.5/bin/python3 setup.py build
    running build
    running build_py
    creating build
    creating build/lib
    creating build/lib/dogpile
    copying dogpile/lock.py -> build/lib/dogpile
    copying dogpile/__init__.py -> build/lib/dogpile
    copying dogpile/core.py -> build/lib/dogpile
    creating build/lib/dogpile/util
    copying dogpile/util/langhelpers.py -> build/lib/dogpile/util
    copying dogpile/util/compat.py -> build/lib/dogpile/util
    copying dogpile/util/readwrite_lock.py -> build/lib/dogpile/util
    copying dogpile/util/nameregistry.py -> build/lib/dogpile/util
    copying dogpile/util/__init__.py -> build/lib/dogpile/util
    creating build/lib/dogpile/cache
    copying dogpile/cache/api.py -> build/lib/dogpile/cache
    copying dogpile/cache/exception.py -> build/lib/dogpile/cache
    copying dogpile/cache/util.py -> build/lib/dogpile/cache
    copying dogpile/cache/__init__.py -> build/lib/dogpile/cache
    copying dogpile/cache/region.py -> build/lib/dogpile/cache
    copying dogpile/cache/proxy.py -> build/lib/dogpile/cache
    creating build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/null.py -> build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/memory.py -> build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/redis.py -> build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/file.py -> build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/__init__.py -> build/lib/dogpile/cache/backends
    copying dogpile/cache/backends/memcached.py -> build/lib/dogpile/cache/backends
    creating build/lib/dogpile/cache/plugins
    copying dogpile/cache/plugins/mako_cache.py -> build/lib/dogpile/cache/plugins
    copying dogpile/cache/plugins/__init__.py -> build/lib/dogpile/cache/plugins
    

    dogpile doesn't use namespace packages anymore so make sure you're on the latest version and uninstall any old versions of dogpile.core / dogpile.cache.

  2. Log in to comment