Failed to open socket

Issue #2 closed
Former user created an issue

[ INFO] [1458829197.034626673]: Preparing to listen on interface eth0 port 3000 for packets from ip

[FATAL] [1458829197.034698203]: Failed to open socket

Comments (9)

  1. Sriram

    I forgot to login,

    So i get this error when i run the node. I ran wireshark and see data getting sent to the same ip address and port.

    Can you suggest what I should do, to solve the problem?


  2. Kevin Hallenbeck

    The ip address and interface parameters are optional. Without them, it will listen for packets from all address on all interfaces. Also, I think binding to an interface like eth0 requires higher privileges, which might have caused the 'failed to open socket' error.

    If you successfully get this driver going, can you post your model number here? I only have access to a RT3000v2, and it would be nice to know what OXTS sensors have been tested with this driver.

  3. Sriram

    hi Kevin,

    thanks a lot.. now i'm connected to the OXTS sensor and get a message saying connected to RT3003v2 (It works for this sensor!!)

    but when I view the topics I don't get any data (even the imu data, which i can see using the NAVgraph application from OXTS ).

  4. Kevin Hallenbeck

    From the FAQ on the front page of this driver:

    I see Connected to Oxford GPS at <ip_address>:3000, but no messages are published.
    Invalid data is not published. Move faster than 5 m/s to initialize the sensor.

  5. Log in to comment