Crash when within certain range of an Enderman

Create issue
Issue #72 resolved
ckay1100 created an issue

Crash details state a java.lang.IllegalAccessError

Other crash reports depicting similar circumstances:

One

Two

Comments (16)

  1. Rittjitt

    Have the same error. Tried replacing the Enderman files and deleting them. That does not work and you can not enter a world if the files are missing. start of the error for me is ---- Minecraft Crash Report ---- // You're mean.

    Time: 10/17/16 5:09 PM Description: Ticking entity

    java.lang.IllegalAccessError: tried to access method net.minecraft.entity.monster.EntityEnderman.func_70821_d(Lnet/minecraft/entity/player/EntityPlayer;)Z from class net.mobtalker.mobtalker2.entity.ai.MobTalkerAiEndermanTarget at net.mobtalker.mobtalker2.entity.ai.MobTalkerAiEndermanTarget.func_75253_b(MobTalkerAiEndermanTarget.java:38)

  2. Rittjitt

    Fixed the problem for the 0.6.0 version. download the file, install it into your mods. launch mine craft with the forge profile on. go to mods then to mob talker 2 and click on general and disable Enderman. I will try to fix the problem for the other releases, but to do so i need to configure the files manually because the in game configure does not work for the other versions.

  3. mezzodrinker
    • changed milestone to 0.7.5
    • removed responsible

    Unassigned bioshacker001 as it seems unlikely they'll return anytime soon.

  4. mezzodrinker

    Reproducible with built JAR file. Player does not need to look at the Enderman, being within a certain range (4 chunks? render distance? chunk loading distance?) is sufficient. Crash occurs even though the method in question (EntityEnderman.shouldAttackPlayer/EntityEnderman.func_70821_d) is specified in the Access Transformer configuration. 🤔

  5. mezzodrinker

    Crash occurs because the Access Transformer was not added to the MANIFEST.MF file during build. Due to this, the Access Transformer mappings were not loaded by Forge and the access error occurred. Meanwhile, the dev environment was fine because the decompiled source was built with the Access Transformer enabled due to ForgeGradle being able to find it.

    Should be a quick fix.

  6. mezzodrinker

    Add FMLAT attribute to MANIFEST.MF (fixes #72)

    Moved mobtalker2_at.cfg from resources/META-INF to resources directory as one directory for one file is not necessary.

    → <<cset b6f571975231>>

  7. Log in to comment