Specify Partial Test option error

Issue #1433 resolved
Matej Mercina created an issue

Just tried the new Specify Tests option for deploy to production Org.

These are my deploy settings

And this is the error I get when clicking deploy

I’ve also tried to disable “Ignore Warnings” but there’s no difference.

Official response

Comments (12)

  1. Scott Wells repo owner

    Thanks for filing. Does it work properly if you choose "Run Local Tests" or does it always fail in this manner?

  2. Scott Wells repo owner

    Until I can determine and implement a fix for this, the workaround would be to roll back to the previous version. Just download the previous build from https://plugins.jetbrains.com/plugin/10253-illuminated-cloud-2/versions and install it using Settings/Preferences>Plugins>Install plugin from disk (under the gear drop-down).

    I'll try to get a fix out today or Monday if possible, but before I can do that I'll need to understand why it's not setting rollbackOnError=false for you in the situation where it's disabling the Ignore Errors checkbox.

  3. Daniel Ebel

    Hi Scott,

    just for your information, the same error happens for me too. I chose ‘Run Local Tests’ though.

    I really like the new feature because it makes using change sets obsolete, but as long as it doesn’t work in production, I gotta roll back.

    Hoping for a fix soon!


  4. Matej Mercina reporter

    Hey Scott,

    just tried this out - this also happens for Run Local Tests. I’ve also tries this on a completely different project with different orgs.

  5. Scott Wells repo owner

    I'm attaching a build that is basically plus some additional debug logging. If you've experienced this issue, please download the attached archive (do not extract it) and install it using Settings/Preferences>Plugins>Install plugin from disk (under the gear drop-down menu). The enable debug logging for metadata deployment and reproduce the issue. Finally either attach or email the resulting idea.log for review. Hopefully it'll clarify why this is happening so that I can provide a quick fix.

  6. Scott Wells repo owner

    Matej sent a log and it showed me what's happening. It's a dumb boolean inversion bug on my part. I'm attaching a new build that should fix it. Please let me know if it doesn't.

  7. Scott Wells repo owner

    Perfect! Thanks for helping get to the bottom of it, and again, sorry for the bug. I'll get an official release out Monday morning with this fix and a few other minor things I've been working on.

  8. Log in to comment