TLS > 1.0 required

Issue #338 resolved
Marius Blajevschi created an issue

Hi Scott,

I believe that the TLS critical update was applied to my env and now, IC cannot save changes. I'm getting: "UNSUPPORTED CLIENT: TLS 1.0 has beed disabled in this organization. Please use TLS 1.1 or higher ...".

I haven't found any TLS setting for IC ... is there any way to get around this? I am currently blocked.

Also, in my org, I am unable to find the critical update for TLS in order to disable it ...

Regard, Marius

Official response

Comments (6)

  1. Scott Wells repo owner

    Marius, if your org was created after Salesforce Summer '16 or if it's a sandbox, I believe the TLS 1.1+ update is forced upon you. Otherwise you can deactivate it under the Salesforce Setup menu under Critical Updates. Assuming that it's enabled for your org, you'll need to update IntelliJ IDEA to use a newer JRE that supports TLS 1.1+ as well:

    I'll leave this open until you determine which options are available to you and which you end up using to resolve the issue.

    Regards, Scott

  2. Marius Blajevschi reporter

    Scott, yes, it is a sandbox and yes it is enabled and I cannot go back.

    So the solution is to update to a JRE that supports TLS 1.1+ and IC will just use it right?


  3. Scott Wells repo owner

    Marius, you'll also need to follow the link supplied above to tell IntelliJ/IC to use the updated JRE for its own runtime. Let me know if you're unable to get that going properly, or if doing so doesn't resolve the issue for you.

  4. Marius Blajevschi reporter

    Yes, I understood that Scott and I was able to fix it.

    OS: MacOS El Capitan IntelliJ Idea 14.

    I order to fix it, I needed to edit ~/Applications/Intellij Idea 14/Contents/Info.plist and change the setting:

    <key>JVMVersion</key> from <string>1.6*, 1.7+</string> to <string>1.7+</string>. I already have JRE 1.8 installed.

    Thanks Scott!

  5. Log in to comment