Ubuntu 14.04 64bit from Dec.1 2014 gives libqmuparser.so.2 error

Issue #197 resolved
Former user created an issue

Dec. 1st Ubuntu Trusty 14.04 64bit build file valentina_0.2.8+797+39+201412011501~ubuntu14.04.1_amd64.deb does not launch from Unity or from command line.

susan@Susan-system76:/usr/bin$ valentina valentina: error while loading shared libraries: libqmuparser.so.2: cannot open shared object file: No such file or directory

Comments (13)

  1. Former user Account Deleted

    I rolled back Dec 1's version back to build from November 26. Got same error. susan@Susan-system76:/usr/bin$ valentina valentina: error while loading shared libraries: libqmuparser.so.2: cannot open shared object file: No such file or directory

    Just for completeness, I confirmed that libqmuparser.so.2 was installed: susan@Susan-system76:/usr/bin$ locate libqmuparser.so.2 /usr/lib/libqmuparser.so.2 /usr/lib/libqmuparser.so.2.2 /usr/lib/libqmuparser.so.2.2.4

    I do not know if this version worked, as I did not notice when it was installed.

  2. Former user Account Deleted

    I rolled November 26's version back to build from November 25.
    Getting same errors. Valentina will not execute. The November 25 version worked when initially installed, so I am a bit confused by this error.

  3. Former user Account Deleted

    Downloaded Bitbucket Dec. 3 code & built with Qt 5.3.2 without error. Valentina.pro opens and appears to run properly.

  4. Roman Telezhynskyi repo owner

    @tusuzu, this issue about path to 64 bit libraries. After issue #191: cannot start application after 'sudo make install' i changed path installing libraries on 64 bit system to /usr/lib64. Using /usr/lib on 64 bit system wrong because we build libraries for 64 bit too. Can you say me if you have libraries in /usr/lib64 and file /etc/ld.so.conf have path to /usr/lib64? Because if not this mean command ldconfig doesn't cache our libraries. See file Valentina/dist/debian/valentina.postinst. This script should run after installation. Maybe setting LD_LIBRARY_PATH fix issue.

  5. Roman Telezhynskyi repo owner
    As you can see, the GLEW files are essentially the only things in the /usr/lib64 directory. I have issued the ldconfig command as root but that has not fixed the problem. 
    It seems like something needs to be added to /etc/ld.so.conf or one of the other conf files in /etc/ld.so.conf.d, or maybe I can just move these GLEW files into 
    /usr/lib/x86_64-linux-gnu/ ?
    ldconfig only scans the directories which are listed in ld.so.conf, or in files included from it. If GLEW is the only library in /usr/lib64, that suggests that your Linux 
    distribution doesn't use that directory, so ld.so.conf probably doesn't reference it. You can either modify ld.so.conf or move the GLEW libraries. If the libraries 
    aren't part of the distribution, they should probably go somewhere under /usr/local rather than under /usr.

    So, we need someone who say where install 64 bit libraries. /usr/local/lib64? ld.so.conf, i think, have answer for this question. One quick way is create file valentina.conf in /etc/ld.so.conf.d with path to libraries and then run ldconfig.

  6. Former user Account Deleted

    Tried it, works great!
    But it wouldn't install until the previous later-versioned Valentina was removed with sudo apt-get remove valentina

  7. Roman Telezhynskyi repo owner

    Yes, i know. This is because of package number. I use this schema {debupstream}+{revno}+{revno:packaging}+{time}.
    For example {valentina_0.2.8}+{791}+{39}+{201411251150}. And something wrong with {revno} number. Somehow bazzar made it smaller of previous value.
    My history record say we had:
    valentina_0.2.8+751+40+201412071139~ubuntu14.04.1.deb <= now
    valentina_0.2.8+751+40+201412071139~ubuntu14.10.1.deb <= now

  8. Log in to comment